summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2017-02-03 16:01:22 +1100
committerDamien Miller <djm@mindrot.org>2017-02-03 16:03:05 +1100
commit523db8540b720c4d21ab0ff6f928476c70c38aab (patch)
tree25ac554b0e68ffab99a462e67893d2f6b37f088d /configure.ac
parentc998bf0afa1a01257a53793eba57941182e9e0b7 (diff)
prefer to use ldns-config to find libldns
Should fix bz#2603 - "Build with ldns and without kerberos support fails if ldns compiled with kerberos support" by including correct cflags/libs ok dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac52
1 files changed, 32 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 0911e7c81..972addfeb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1474,36 +1474,47 @@ AC_ARG_WITH([skey],
1474LDNS_MSG="no" 1474LDNS_MSG="no"
1475AC_ARG_WITH(ldns, 1475AC_ARG_WITH(ldns,
1476 [ --with-ldns[[=PATH]] Use ldns for DNSSEC support (optionally in PATH)], 1476 [ --with-ldns[[=PATH]] Use ldns for DNSSEC support (optionally in PATH)],
1477 [ 1477 [
1478 if test "x$withval" != "xno" ; then 1478 ldns=""
1479 1479 if test "x$withval" = "xyes" ; then
1480 if test "x$withval" != "xyes" ; then 1480 AC_PATH_TOOL([LDNSCONFIG], [ldns-config], [no])
1481 CPPFLAGS="$CPPFLAGS -I${withval}/include" 1481 if test "x$PKGCONFIG" = "xno"; then
1482 LDFLAGS="$LDFLAGS -L${withval}/lib" 1482 CPPFLAGS="$CPPFLAGS -I${withval}/include"
1483 fi 1483 LDFLAGS="$LDFLAGS -L${withval}/lib"
1484 1484 LIBS="-lldns $LIBS"
1485 AC_DEFINE(HAVE_LDNS, 1, [Define if you want ldns support]) 1485 ldns=yes
1486 LIBS="-lldns $LIBS" 1486 else
1487 LDNS_MSG="yes" 1487 LIBS="$LIBS `$LDNSCONFIG --libs`"
1488 CPPFLAGS="$CPPFLAGS `$LDNSCONFIG --cflags`"
1489 fi
1490 elif test "x$withval" != "xno" ; then
1491 CPPFLAGS="$CPPFLAGS -I${withval}/include"
1492 LDFLAGS="$LDFLAGS -L${withval}/lib"
1493 LIBS="-lldns $LIBS"
1494 ldns=yes
1495 fi
1488 1496
1489 AC_MSG_CHECKING([for ldns support]) 1497 # Verify that it works.
1490 AC_LINK_IFELSE( 1498 if test "x$ldns" = "xyes" ; then
1491 [AC_LANG_SOURCE([[ 1499 AC_DEFINE(HAVE_LDNS, 1, [Define if you want ldns support])
1500 LDNS_MSG="yes"
1501 AC_MSG_CHECKING([for ldns support])
1502 AC_LINK_IFELSE(
1503 [AC_LANG_SOURCE([[
1492#include <stdio.h> 1504#include <stdio.h>
1493#include <stdlib.h> 1505#include <stdlib.h>
1494#include <stdint.h> 1506#include <stdint.h>
1495#include <ldns/ldns.h> 1507#include <ldns/ldns.h>
1496int main() { ldns_status status = ldns_verify_trusted(NULL, NULL, NULL, NULL); status=LDNS_STATUS_OK; exit(0); } 1508int main() { ldns_status status = ldns_verify_trusted(NULL, NULL, NULL, NULL); status=LDNS_STATUS_OK; exit(0); }
1497 ]]) 1509 ]])
1498 ], 1510 ],
1499 [AC_MSG_RESULT(yes)], 1511 [AC_MSG_RESULT(yes)],
1500 [ 1512 [
1501 AC_MSG_RESULT(no) 1513 AC_MSG_RESULT(no)
1502 AC_MSG_ERROR([** Incomplete or missing ldns libraries.]) 1514 AC_MSG_ERROR([** Incomplete or missing ldns libraries.])
1503 ]) 1515 ])
1504 fi 1516 fi
1505 ] 1517])
1506)
1507 1518
1508# Check whether user wants libedit support 1519# Check whether user wants libedit support
1509LIBEDIT_MSG="no" 1520LIBEDIT_MSG="no"
@@ -5083,6 +5094,7 @@ echo " Smartcard support: $SCARD_MSG"
5083echo " S/KEY support: $SKEY_MSG" 5094echo " S/KEY support: $SKEY_MSG"
5084echo " MD5 password support: $MD5_MSG" 5095echo " MD5 password support: $MD5_MSG"
5085echo " libedit support: $LIBEDIT_MSG" 5096echo " libedit support: $LIBEDIT_MSG"
5097echo " libldns support: $LDNS_MSG"
5086echo " Solaris process contract support: $SPC_MSG" 5098echo " Solaris process contract support: $SPC_MSG"
5087echo " Solaris project support: $SP_MSG" 5099echo " Solaris project support: $SP_MSG"
5088echo " Solaris privilege support: $SPP_MSG" 5100echo " Solaris privilege support: $SPP_MSG"