summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2016-07-15 13:54:31 +1000
committerDamien Miller <djm@mindrot.org>2016-07-15 14:28:59 +1000
commit5fbe93fc6fbb2fe211e035703dec759d095e3dd8 (patch)
tree7702724da9131e049624dd3abc3e6b854db9ba95 /configure.ac
parent679ce88ec2a8e2fe6515261c489e8c1449bb9da9 (diff)
add a --disable-pkcs11 knob
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4f525b5d2..21ef38988 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1804,8 +1804,18 @@ AC_LINK_IFELSE(
1804 [AC_DEFINE([HAVE_ISBLANK], [1], [Define if you have isblank(3C).]) 1804 [AC_DEFINE([HAVE_ISBLANK], [1], [Define if you have isblank(3C).])
1805]) 1805])
1806 1806
1807disable_pkcs11=
1808AC_ARG_ENABLE([pkcs11],
1809 [ --disable-pkcs11 disable PKCS#11 support code [no]],
1810 [
1811 if test "x$enableval" = "xno" ; then
1812 disable_pkcs11=1
1813 fi
1814 ]
1815)
1816
1807# PKCS11 depends on OpenSSL. 1817# PKCS11 depends on OpenSSL.
1808if test "x$openssl" = "xyes" ; then 1818if test "x$openssl" = "xyes" && test "x$disable_pkcs11" = "x"; then
1809 # PKCS#11 support requires dlopen() and co 1819 # PKCS#11 support requires dlopen() and co
1810 AC_SEARCH_LIBS([dlopen], [dl], 1820 AC_SEARCH_LIBS([dlopen], [dl],
1811 [AC_DEFINE([ENABLE_PKCS11], [], [Enable for PKCS#11 support])] 1821 [AC_DEFINE([ENABLE_PKCS11], [], [Enable for PKCS#11 support])]