summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2016-07-15 13:44:38 +1000
committerDamien Miller <djm@mindrot.org>2016-07-15 14:28:59 +1000
commit679ce88ec2a8e2fe6515261c489e8c1449bb9da9 (patch)
tree50217888e98c1fb47ac115534443130c38fc2c34 /configure.ac
parented877ef653847d056bb433975d731b7a1132a979 (diff)
fix newline escaping for unsupported_algorithms
The hmac-ripemd160 was incorrect and could lead to broken Makefiles on systems that lacked support for it, but I made all the others consistent too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 20 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 2439e3948..4f525b5d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2643,7 +2643,8 @@ if test "x$openssl" = "xyes" ; then
2643 [ 2643 [
2644 AC_MSG_RESULT([no]) 2644 AC_MSG_RESULT([no])
2645 unsupported_algorithms="$unsupported_cipers \ 2645 unsupported_algorithms="$unsupported_cipers \
2646 aes128-gcm@openssh.com aes256-gcm@openssh.com" 2646 aes128-gcm@openssh.com \
2647 aes256-gcm@openssh.com"
2647 ] 2648 ]
2648 ) 2649 )
2649 2650
@@ -2686,16 +2687,18 @@ if test "x$openssl" = "xyes" ; then
2686 # Search for SHA256 support in libc and/or OpenSSL 2687 # Search for SHA256 support in libc and/or OpenSSL
2687 AC_CHECK_FUNCS([SHA256_Update EVP_sha256], , 2688 AC_CHECK_FUNCS([SHA256_Update EVP_sha256], ,
2688 [unsupported_algorithms="$unsupported_algorithms \ 2689 [unsupported_algorithms="$unsupported_algorithms \
2689 hmac-sha2-256 hmac-sha2-512 \ 2690 hmac-sha2-256 \
2691 hmac-sha2-512 \
2690 diffie-hellman-group-exchange-sha256 \ 2692 diffie-hellman-group-exchange-sha256 \
2691 hmac-sha2-256-etm@openssh.com hmac-sha2-512-etm@openssh.com" 2693 hmac-sha2-256-etm@openssh.com \
2694 hmac-sha2-512-etm@openssh.com"
2692 ] 2695 ]
2693 ) 2696 )
2694 # Search for RIPE-MD support in OpenSSL 2697 # Search for RIPE-MD support in OpenSSL
2695 AC_CHECK_FUNCS([EVP_ripemd160], , 2698 AC_CHECK_FUNCS([EVP_ripemd160], ,
2696 [unsupported_algorithms="$unsupported_algorithms \ 2699 [unsupported_algorithms="$unsupported_algorithms \
2697 hmac-ripemd160 2700 hmac-ripemd160 \
2698 hmac-ripemd160@openssh.com 2701 hmac-ripemd160@openssh.com \
2699 hmac-ripemd160-etm@openssh.com" 2702 hmac-ripemd160-etm@openssh.com"
2700 ] 2703 ]
2701 ) 2704 )
@@ -2796,24 +2799,30 @@ if test "x$openssl" = "xyes" ; then
2796 TEST_SSH_ECC=yes 2799 TEST_SSH_ECC=yes
2797 COMMENT_OUT_ECC="" 2800 COMMENT_OUT_ECC=""
2798 else 2801 else
2799 unsupported_algorithms="$unsupported_algorithms ecdsa-sha2-nistp256 \ 2802 unsupported_algorithms="$unsupported_algorithms \
2800 ecdh-sha2-nistp256 ecdsa-sha2-nistp256-cert-v01@openssh.com" 2803 ecdsa-sha2-nistp256 \
2804 ecdh-sha2-nistp256 \
2805 ecdsa-sha2-nistp256-cert-v01@openssh.com"
2801 fi 2806 fi
2802 if test x$enable_nistp384 = x1; then 2807 if test x$enable_nistp384 = x1; then
2803 AC_DEFINE([OPENSSL_HAS_NISTP384], [1], [libcrypto has NID_secp384r1]) 2808 AC_DEFINE([OPENSSL_HAS_NISTP384], [1], [libcrypto has NID_secp384r1])
2804 TEST_SSH_ECC=yes 2809 TEST_SSH_ECC=yes
2805 COMMENT_OUT_ECC="" 2810 COMMENT_OUT_ECC=""
2806 else 2811 else
2807 unsupported_algorithms="$unsupported_algorithms ecdsa-sha2-nistp384 \ 2812 unsupported_algorithms="$unsupported_algorithms \
2808 ecdh-sha2-nistp384 ecdsa-sha2-nistp384-cert-v01@openssh.com" 2813 ecdsa-sha2-nistp384 \
2814 ecdh-sha2-nistp384 \
2815 ecdsa-sha2-nistp384-cert-v01@openssh.com"
2809 fi 2816 fi
2810 if test x$enable_nistp521 = x1; then 2817 if test x$enable_nistp521 = x1; then
2811 AC_DEFINE([OPENSSL_HAS_NISTP521], [1], [libcrypto has NID_secp521r1]) 2818 AC_DEFINE([OPENSSL_HAS_NISTP521], [1], [libcrypto has NID_secp521r1])
2812 TEST_SSH_ECC=yes 2819 TEST_SSH_ECC=yes
2813 COMMENT_OUT_ECC="" 2820 COMMENT_OUT_ECC=""
2814 else 2821 else
2815 unsupported_algorithms="$unsupported_algorithms ecdh-sha2-nistp521 \ 2822 unsupported_algorithms="$unsupported_algorithms \
2816 ecdsa-sha2-nistp521 ecdsa-sha2-nistp521-cert-v01@openssh.com" 2823 ecdh-sha2-nistp521 \
2824 ecdsa-sha2-nistp521 \
2825 ecdsa-sha2-nistp521-cert-v01@openssh.com"
2817 fi 2826 fi
2818 2827
2819 AC_SUBST([TEST_SSH_ECC]) 2828 AC_SUBST([TEST_SSH_ECC])