summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2004-05-30 21:38:51 -0700
committerTim Rice <tim@multitalents.net>2004-05-30 21:38:51 -0700
commit6f1f758cca33555f4f81691d10d3f8996bc6ab45 (patch)
tree9d9cbccc8fe34d71cbd0662cf9e2036cc900fee5 /configure.ac
parente061b1598a99c7c978f2e05f6d7aa86b6dba9d73 (diff)
- (tim) [configure.ac Makefile.in] Add support for "make package" ok djm@
- (tim) [buildpkg.sh.in] New file. A more flexible version of contrib/solaris/buildpkg.sh used for "make package".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 76ac0e06c..9f5d11935 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.218 2004/05/23 04:09:40 djm Exp $ 1# $Id: configure.ac,v 1.219 2004/05/31 04:38:51 tim Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -38,6 +38,13 @@ AC_PATH_PROG(TEST_MINUS_S_SH, ksh)
38AC_PATH_PROG(TEST_MINUS_S_SH, sh) 38AC_PATH_PROG(TEST_MINUS_S_SH, sh)
39AC_PATH_PROG(SH, sh) 39AC_PATH_PROG(SH, sh)
40 40
41dnl for buildpkg.sh
42AC_PATH_PROG(PATH_GROUPADD_PROG, groupadd, groupadd,
43 [/usr/sbin${PATH_SEPARATOR}/etc])
44AC_PATH_PROG(PATH_USERADD_PROG, useradd, useradd,
45 [/usr/sbin${PATH_SEPARATOR}/etc])
46AC_CHECK_PROG(MAKE_PACKAGE_SUPPORTED, pkgmk, yes, no)
47
41# System features 48# System features
42AC_SYS_LARGEFILE 49AC_SYS_LARGEFILE
43 50
@@ -2908,7 +2915,7 @@ if test "$ac_cv_lib_pam_pam_set_item" = yes ; then
2908fi 2915fi
2909 2916
2910AC_EXEEXT 2917AC_EXEEXT
2911AC_CONFIG_FILES([Makefile openbsd-compat/Makefile scard/Makefile ssh_prng_cmds]) 2918AC_CONFIG_FILES([Makefile buildpkg.sh openbsd-compat/Makefile scard/Makefile ssh_prng_cmds])
2912AC_OUTPUT 2919AC_OUTPUT
2913 2920
2914# Print summary of options 2921# Print summary of options
@@ -2973,6 +2980,10 @@ echo " Libraries: ${LIBWRAP} ${LIBPAM} ${LIBS}"
2973 2980
2974echo "" 2981echo ""
2975 2982
2983if test "x$MAKE_PACKAGE_SUPPORTED" = "xyes" ; then
2984 echo "SVR4 style packages are supported with \"make package\"\n"
2985fi
2986
2976if test "x$PAM_MSG" = "xyes" ; then 2987if test "x$PAM_MSG" = "xyes" ; then
2977 echo "PAM is enabled. You may need to install a PAM control file " 2988 echo "PAM is enabled. You may need to install a PAM control file "
2978 echo "for sshd, otherwise password authentication may fail. " 2989 echo "for sshd, otherwise password authentication may fail. "