summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Wilkinson <simon@sxw.org.uk>2014-02-09 16:09:48 +0000
committerColin Watson <cjwatson@debian.org>2018-10-20 22:54:00 +0100
commit72b1d308e6400194ef6e4e7dd45bfa48fa39b5e6 (patch)
tree2a3b57ae5446f4273804064ccc42659adfc2a3b2 /configure.ac
parent3d246f10429fc9a37b98eabef94fe8dc7c61002b (diff)
GSSAPI key exchange support
This patch has been rejected upstream: "None of the OpenSSH developers are in favour of adding this, and this situation has not changed for several years. This is not a slight on Simon's patch, which is of fine quality, but just that a) we don't trust GSSAPI implementations that much and b) we don't like adding new KEX since they are pre-auth attack surface. This one is particularly scary, since it requires hooks out to typically root-owned system resources." However, quite a lot of people rely on this in Debian, and it's better to have it merged into the main openssh package rather than having separate -krb5 packages (as we used to have). It seems to have a generally good security history. Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1242 Last-Updated: 2018-10-20 Patch-Name: gssapi.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7379ab358..023e7cc55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -664,6 +664,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
664 [Use tunnel device compatibility to OpenBSD]) 664 [Use tunnel device compatibility to OpenBSD])
665 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 665 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
666 [Prepend the address family to IP tunnel traffic]) 666 [Prepend the address family to IP tunnel traffic])
667 AC_MSG_CHECKING([if we have the Security Authorization Session API])
668 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
669 [SessionCreate(0, 0);],
670 [ac_cv_use_security_session_api="yes"
671 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
672 [platform has the Security Authorization Session API])
673 LIBS="$LIBS -framework Security"
674 AC_MSG_RESULT([yes])],
675 [ac_cv_use_security_session_api="no"
676 AC_MSG_RESULT([no])])
677 AC_MSG_CHECKING([if we have an in-memory credentials cache])
678 AC_TRY_COMPILE(
679 [#include <Kerberos/Kerberos.h>],
680 [cc_context_t c;
681 (void) cc_initialize (&c, 0, NULL, NULL);],
682 [AC_DEFINE([USE_CCAPI], [1],
683 [platform uses an in-memory credentials cache])
684 LIBS="$LIBS -framework Security"
685 AC_MSG_RESULT([yes])
686 if test "x$ac_cv_use_security_session_api" = "xno"; then
687 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
688 fi],
689 [AC_MSG_RESULT([no])]
690 )
667 m4_pattern_allow([AU_IPv]) 691 m4_pattern_allow([AU_IPv])
668 AC_CHECK_DECL([AU_IPv4], [], 692 AC_CHECK_DECL([AU_IPv4], [],
669 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 693 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])