summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2006-04-22 21:26:08 +1000
committerDamien Miller <djm@mindrot.org>2006-04-22 21:26:08 +1000
commit73b42d2bb058da914828b53f2951954560a5b6eb (patch)
tree7271e92211fab0a06b0d36f162801b073220c5bf /configure.ac
parent2eaf37d899a55c253ad42d13534a824bce9c8ed2 (diff)
- (djm) [Makefile.in configure.ac session.c sshpty.c]
[contrib/redhat/sshd.init openbsd-compat/Makefile.in] [openbsd-compat/openbsd-compat.h openbsd-compat/port-linux.c] [openbsd-compat/port-linux.h] Add support for SELinux, setting the execution and TTY contexts. based on patch from Daniel Walsh, bz #880; ok dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9e037ab0e..093c17643 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.338 2006/03/15 21:14:34 dtucker Exp $ 1# $Id: configure.ac,v 1.339 2006/04/22 11:26:08 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.338 $) 18AC_REVISION($Revision: 1.339 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -3000,6 +3000,23 @@ int main()
3000 [#include <arpa/nameser.h>]) 3000 [#include <arpa/nameser.h>])
3001 ]) 3001 ])
3002 3002
3003# Check whether user wants SELinux support
3004SELINUX_MSG="no"
3005LIBSELINUX=""
3006AC_ARG_WITH(selinux,
3007 [ --with-selinux Enable SELinux support],
3008 [ if test "x$withval" != "xno" ; then
3009 AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.])
3010 SELINUX_MSG="yes"
3011 AC_CHECK_HEADER([selinux/selinux.h], ,
3012 AC_MSG_ERROR(SELinux support requires selinux.h header))
3013 AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ],
3014 AC_MSG_ERROR(SELinux support requires libselinux library))
3015 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level)
3016 fi ]
3017)
3018AC_SUBST(LIBSELINUX)
3019
3003# Check whether user wants Kerberos 5 support 3020# Check whether user wants Kerberos 5 support
3004KRB5_MSG="no" 3021KRB5_MSG="no"
3005AC_ARG_WITH(kerberos5, 3022AC_ARG_WITH(kerberos5,
@@ -3818,6 +3835,7 @@ fi
3818echo " Manpage format: $MANTYPE" 3835echo " Manpage format: $MANTYPE"
3819echo " PAM support: $PAM_MSG" 3836echo " PAM support: $PAM_MSG"
3820echo " KerberosV support: $KRB5_MSG" 3837echo " KerberosV support: $KRB5_MSG"
3838echo " SELinux support: $SELINUX_MSG"
3821echo " Smartcard support: $SCARD_MSG" 3839echo " Smartcard support: $SCARD_MSG"
3822echo " S/KEY support: $SKEY_MSG" 3840echo " S/KEY support: $SKEY_MSG"
3823echo " TCP Wrappers support: $TCPW_MSG" 3841echo " TCP Wrappers support: $TCPW_MSG"