summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2003-05-18 20:52:40 +1000
committerDamien Miller <djm@mindrot.org>2003-05-18 20:52:40 +1000
commit7e1bbc55af32d8f5d81200323198c65b548faaad (patch)
treebe317e9ceb17268984b58d8f6c243123a66107f2 /configure.ac
parent20a8f97b034df418d0e5e04b11000b44ab07e628 (diff)
- (djm) Remove IPv4 by default hack now that we can specify AF in config
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 1 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 99a85264c..bdc198592 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.121 2003/05/15 11:42:59 dtucker Exp $ 1# $Id: configure.ac,v 1.122 2003/05/18 10:52:40 djm Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -95,7 +95,6 @@ case "$host" in
95 AC_DEFINE(HAVE_CYGWIN) 95 AC_DEFINE(HAVE_CYGWIN)
96 AC_DEFINE(USE_PIPES) 96 AC_DEFINE(USE_PIPES)
97 AC_DEFINE(DISABLE_SHADOW) 97 AC_DEFINE(DISABLE_SHADOW)
98 AC_DEFINE(IPV4_DEFAULT)
99 AC_DEFINE(IP_TOS_IS_BROKEN) 98 AC_DEFINE(IP_TOS_IS_BROKEN)
100 AC_DEFINE(NO_X11_UNIX_SOCKETS) 99 AC_DEFINE(NO_X11_UNIX_SOCKETS)
101 AC_DEFINE(NO_IPPORT_RESERVED_CONCEPT) 100 AC_DEFINE(NO_IPPORT_RESERVED_CONCEPT)
@@ -2249,18 +2248,6 @@ AC_ARG_WITH(superuser-path,
2249) 2248)
2250 2249
2251 2250
2252# Whether to force IPv4 by default (needed on broken glibc Linux)
2253IPV4_HACK_MSG="no"
2254AC_ARG_WITH(ipv4-default,
2255 [ --with-ipv4-default Use IPv4 by connections unless '-6' specified],
2256 [
2257 if test "x$withval" != "xno" ; then
2258 AC_DEFINE(IPV4_DEFAULT)
2259 IPV4_HACK_MSG="yes"
2260 fi
2261 ]
2262)
2263
2264AC_MSG_CHECKING([if we need to convert IPv4 in IPv6-mapped addresses]) 2251AC_MSG_CHECKING([if we need to convert IPv4 in IPv6-mapped addresses])
2265IPV4_IN6_HACK_MSG="no" 2252IPV4_IN6_HACK_MSG="no"
2266AC_ARG_WITH(4in6, 2253AC_ARG_WITH(4in6,
@@ -2601,7 +2588,6 @@ echo " S/KEY support: $SKEY_MSG"
2601echo " TCP Wrappers support: $TCPW_MSG" 2588echo " TCP Wrappers support: $TCPW_MSG"
2602echo " MD5 password support: $MD5_MSG" 2589echo " MD5 password support: $MD5_MSG"
2603echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 2590echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
2604echo " Use IPv4 by default hack: $IPV4_HACK_MSG"
2605echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 2591echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
2606echo " BSD Auth support: $BSD_AUTH_MSG" 2592echo " BSD Auth support: $BSD_AUTH_MSG"
2607echo " Random number source: $RAND_MSG" 2593echo " Random number source: $RAND_MSG"