summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin Steves <stevesk@pobox.com>2002-04-07 19:22:54 +0000
committerKevin Steves <stevesk@pobox.com>2002-04-07 19:22:54 +0000
commit7ff911216bbc288869c6b8ce99cd812ead66b886 (patch)
tree1046540d4cf19de550198d7d21b2fca00a70e901 /configure.ac
parentb1184bbf2931f064b5b38c3a0fe9440d02c67610 (diff)
- (stevesk) --with-privsep-user; default sshd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b3fa18674..10f238a25 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.38 2002/04/07 18:12:04 stevesk Exp $ 1# $Id: configure.ac,v 1.39 2002/04/07 19:22:54 stevesk Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -993,9 +993,19 @@ AC_ARG_WITH(entropy-timeout,
993 fi 993 fi
994 ] 994 ]
995) 995)
996
997AC_DEFINE_UNQUOTED(ENTROPY_TIMEOUT_MSEC, $entropy_timeout) 996AC_DEFINE_UNQUOTED(ENTROPY_TIMEOUT_MSEC, $entropy_timeout)
998 997
998ssh_privsep_user=sshd
999AC_ARG_WITH(privsep-user,
1000 [ --with-privsep-user Specify non-privileged user for privilege separation],
1001 [
1002 if test -n "$withval"; then
1003 ssh_privsep_user=$withval
1004 fi
1005 ]
1006)
1007AC_DEFINE_UNQUOTED(SSH_PRIVSEP_USER, $ssh_privsep_user)
1008
999# We do this little dance with the search path to insure 1009# We do this little dance with the search path to insure
1000# that programs that we select for use by installed programs 1010# that programs that we select for use by installed programs
1001# (which may be run by the super-user) come from trusted 1011# (which may be run by the super-user) come from trusted