summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2010-10-07 21:39:17 +1100
committerDamien Miller <djm@mindrot.org>2010-10-07 21:39:17 +1100
commita6e121aaa0ab61965db2dcfe8e2ba5d719fbe1e6 (patch)
tree4583d2a94482493f21537611187bd119f496807c /configure.ac
parentaa18063baf35e303832d9ec58204ffaab221de85 (diff)
- djm@cvs.openbsd.org 2010/09/25 09:30:16
[sftp.c configure.ac openbsd-compat/glob.c openbsd-compat/glob.h] make use of new glob(3) GLOB_KEEPSTAT extension to save extra server rountrips to fetch per-file stat(2) information. NB. update openbsd-compat/ glob(3) implementation from OpenBSD libc to match.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 24 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9b67e3d47..4deb0fe2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.453 2010/10/07 10:25:28 djm Exp $ 1# $Id: configure.ac,v 1.454 2010/10/07 10:39:17 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.453 $) 18AC_REVISION($Revision: 1.454 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -1118,6 +1118,28 @@ AC_TRY_COMPILE(
1118 ] 1118 ]
1119) 1119)
1120 1120
1121# Check for g.gl_statv glob() extension
1122AC_MSG_CHECKING(for gl_statv and GLOB_KEEPSTAT extensions for glob)
1123AC_TRY_COMPILE(
1124 [ #include <glob.h> ],
1125 [
1126#ifndef GLOB_KEEPSTAT
1127#error "glob does not support GLOB_KEEPSTAT extension"
1128#endif
1129glob_t g;
1130g.gl_statv = NULL;
1131],
1132 [
1133 AC_DEFINE(GLOB_HAS_GL_STATV, 1,
1134 [Define if your system glob() function has
1135 gl_statv options in glob_t])
1136 AC_MSG_RESULT(yes)
1137 ],
1138 [
1139 AC_MSG_RESULT(no)
1140 ]
1141)
1142
1121AC_CHECK_DECLS(GLOB_NOMATCH, , , [#include <glob.h>]) 1143AC_CHECK_DECLS(GLOB_NOMATCH, , , [#include <glob.h>])
1122 1144
1123AC_MSG_CHECKING([whether struct dirent allocates space for d_name]) 1145AC_MSG_CHECKING([whether struct dirent allocates space for d_name])