summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2008-02-25 21:05:04 +1100
committerDarren Tucker <dtucker@zip.com.au>2008-02-25 21:05:04 +1100
commitacada07b525a21b938ae17c311f529edde932371 (patch)
treeb16b4d9468a2d4b322436661dcc563056747cb09 /configure.ac
parent2c2ac033c15714c8759a307b4a15963dbee83c58 (diff)
- (dtucker) [configure.ac audit-bsm.c] Bug #1420: Add a local implementation
of aug_get_machine for systems that don't have their own (eg OS X, FreeBSD). Help and testing from csjp at FreeBSD org, vgiffin at apple com. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 484d45d53..f9e2d8b34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.389 2008/01/02 07:08:45 dtucker Exp $ 1# $Id: configure.ac,v 1.390 2008/02/25 10:05:04 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.389 $) 18AC_REVISION($Revision: 1.390 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -423,6 +423,11 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
423 [Use tunnel device compatibility to OpenBSD]) 423 [Use tunnel device compatibility to OpenBSD])
424 AC_DEFINE(SSH_TUN_PREPEND_AF, 1, 424 AC_DEFINE(SSH_TUN_PREPEND_AF, 1,
425 [Prepend the address family to IP tunnel traffic]) 425 [Prepend the address family to IP tunnel traffic])
426 m4_pattern_allow(AU_IPv)
427 AC_CHECK_DECL(AU_IPv4, [],
428 AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records])
429 [#include <bsm/audit.h>]
430 )
426 ;; 431 ;;
427*-*-dragonfly*) 432*-*-dragonfly*)
428 SSHDLIBS="$SSHDLIBS -lcrypt" 433 SSHDLIBS="$SSHDLIBS -lcrypt"
@@ -1226,7 +1231,7 @@ AC_ARG_WITH(audit,
1226 AC_CHECK_FUNCS(getaudit, [], 1231 AC_CHECK_FUNCS(getaudit, [],
1227 [AC_MSG_ERROR(BSM enabled and required function not found)]) 1232 [AC_MSG_ERROR(BSM enabled and required function not found)])
1228 # These are optional 1233 # These are optional
1229 AC_CHECK_FUNCS(getaudit_addr) 1234 AC_CHECK_FUNCS(getaudit_addr aug_get_machine)
1230 AC_DEFINE(USE_BSM_AUDIT, 1, [Use BSM audit module]) 1235 AC_DEFINE(USE_BSM_AUDIT, 1, [Use BSM audit module])
1231 ;; 1236 ;;
1232 debug) 1237 debug)