summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2005-08-15 17:48:40 -0700
committerTim Rice <tim@multitalents.net>2005-08-15 17:48:40 -0700
commitc1819c831f044905298ca91cf5848aba3177be00 (patch)
treefa0f54bd582068803b24b65924344109d1b7b243 /configure.ac
parent027e8b10f520866dccfff08afb6ff12cac20ac7f (diff)
- (tim) [configure.ac] corrections to libedit tests. Report and patches
by skeleten AT shillest.net
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a62ee8c43..849112829 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.285 2005/08/10 11:52:36 dtucker Exp $ 1# $Id: configure.ac,v 1.286 2005/08/16 00:48:41 tim Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -1024,15 +1024,16 @@ AC_ARG_WITH(libedit,
1024 [ -lcurses ] 1024 [ -lcurses ]
1025 ) 1025 )
1026 AC_MSG_CHECKING(if libedit version is compatible) 1026 AC_MSG_CHECKING(if libedit version is compatible)
1027 AC_TRY_COMPILE([#include <histedit.h>], 1027 AC_COMPILE_IFELSE(
1028 [ 1028 [AC_LANG_SOURCE([[
1029#include <histedit.h>
1029int main(void) 1030int main(void)
1030{ 1031{
1031 int i = H_SETSIZE; 1032 int i = H_SETSIZE;
1032 el_init("", NULL, NULL, NULL); 1033 el_init("", NULL, NULL, NULL);
1033 exit(0); 1034 exit(0);
1034} 1035}
1035 ], 1036 ]])],
1036 [ AC_MSG_RESULT(yes) ], 1037 [ AC_MSG_RESULT(yes) ],
1037 [ AC_MSG_RESULT(no) 1038 [ AC_MSG_RESULT(no)
1038 AC_MSG_ERROR(libedit version is not compatible) ] 1039 AC_MSG_ERROR(libedit version is not compatible) ]
@@ -1066,6 +1067,7 @@ AC_ARG_WITH(audit,
1066 AC_DEFINE(SSH_AUDIT_EVENTS, [], Use audit debugging module) 1067 AC_DEFINE(SSH_AUDIT_EVENTS, [], Use audit debugging module)
1067 ;; 1068 ;;
1068 no) 1069 no)
1070 AC_MSG_RESULT(no)
1069 ;; 1071 ;;
1070 *) 1072 *)
1071 AC_MSG_ERROR([Unknown audit module $withval]) 1073 AC_MSG_ERROR([Unknown audit module $withval])