summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2009-10-11 21:50:20 +1100
committerDarren Tucker <dtucker@zip.com.au>2009-10-11 21:50:20 +1100
commitc182d993762f86fbdf9e54dd5b0e3e3d229ebc13 (patch)
treec2d047591f1534a0184f0d578ff9f40172937a3c /configure.ac
parent538738d861cefb25d78615b1c299d7b618db870c (diff)
- (dtucker) [configure.ac sftp-client.c] Remove the gyrations required for
dirent d_type and DTTOIF as we've switched OpenBSD to the more portable lstat.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 2 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 80db43af1..0447bd62d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.429 2009/10/07 07:56:10 dtucker Exp $ 1# $Id: configure.ac,v 1.430 2009/10/11 10:50:20 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.429 $) 18AC_REVISION($Revision: 1.430 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -1130,15 +1130,6 @@ int main(void){struct dirent d;exit(sizeof(d.d_name)<=sizeof(char));}
1130 ] 1130 ]
1131) 1131)
1132 1132
1133AC_CHECK_DECL(DTTOIF,
1134 AC_DEFINE(DTTOIF_IN_FS_FFS_DIR_H, 1 , [DTTOIF macro in fs/ffs/dir.h]), ,
1135 [
1136#include <sys/types.h>
1137#include <fs/ffs/dir.h>
1138 ])
1139
1140AC_CHECK_MEMBERS([struct dirent.d_type],,, [#include <dirent.h>])
1141
1142AC_MSG_CHECKING([for /proc/pid/fd directory]) 1133AC_MSG_CHECKING([for /proc/pid/fd directory])
1143if test -d "/proc/$$/fd" ; then 1134if test -d "/proc/$$/fd" ; then
1144 AC_DEFINE(HAVE_PROC_PID, 1, [Define if you have /proc/$pid/fd]) 1135 AC_DEFINE(HAVE_PROC_PID, 1, [Define if you have /proc/$pid/fd])