summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2017-02-03 14:10:34 +1100
committerDarren Tucker <dtucker@zip.com.au>2017-02-03 14:10:34 +1100
commitc61d5ec3c11e7ff9779b6127421d9f166cf10915 (patch)
treea3d4996afbd4974c0f1a852d8bcd3367f788ac5f /configure.ac
parentf25ee13b3e81fd80efeb871dc150fe49d7fc8afd (diff)
Remove _XOPEN_SOURCE from wide char detection.
Having _XOPEN_SOURCE unconditionally causes problems on some platforms and configurations, notably Solaris 64-bit binaries. It was there for the benefit of Linux put the required bits in the *-*linux* section. Patch from yvoinov at gmail.com.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index eb9f45dcc..0911e7c81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -740,6 +740,9 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
740 use_pie=auto 740 use_pie=auto
741 check_for_libcrypt_later=1 741 check_for_libcrypt_later=1
742 check_for_openpty_ctty_bug=1 742 check_for_openpty_ctty_bug=1
743 dnl Target SUSv3/POSIX.1-2001 plus BSD specifics.
744 dnl _DEFAULT_SOURCE is the new name for _BSD_SOURCE
745 CPPFLAGS="$CPPFLAGS -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -D_DEFAULT_SOURCE"
743 AC_DEFINE([PAM_TTY_KLUDGE], [1], 746 AC_DEFINE([PAM_TTY_KLUDGE], [1],
744 [Work around problematic Linux PAM modules handling of PAM_TTY]) 747 [Work around problematic Linux PAM modules handling of PAM_TTY])
745 AC_DEFINE([LOCKED_PASSWD_PREFIX], ["!"], 748 AC_DEFINE([LOCKED_PASSWD_PREFIX], ["!"],
@@ -1771,11 +1774,8 @@ AC_CHECK_FUNCS([ \
1771 warn \ 1774 warn \
1772]) 1775])
1773 1776
1774dnl Wide character support. Linux man page says it needs _XOPEN_SOURCE. 1777dnl Wide character support.
1775saved_CFLAGS="$CFLAGS"
1776CFLAGS="$CFLAGS -D_XOPEN_SOURCE"
1777AC_CHECK_FUNCS([mblen mbtowc nl_langinfo wcwidth]) 1778AC_CHECK_FUNCS([mblen mbtowc nl_langinfo wcwidth])
1778CFLAGS="$saved_CFLAGS"
1779 1779
1780TEST_SSH_UTF8=${TEST_SSH_UTF8:=yes} 1780TEST_SSH_UTF8=${TEST_SSH_UTF8:=yes}
1781AC_MSG_CHECKING([for utf8 locale support]) 1781AC_MSG_CHECKING([for utf8 locale support])