summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2005-08-10 20:34:15 +1000
committerDarren Tucker <dtucker@zip.com.au>2005-08-10 20:34:15 +1000
commitc7572b26611241cb86319193693b940f5dbf47c9 (patch)
tree49cae2de2fd3cc456dc53483d1b09939f0deb412 /configure.ac
parent8bc6b900ed8609d67e75bc7266b9b533a703eb4a (diff)
- (dtucker) [configure.ac] Test libedit library and headers for compatibility.
Report from skeleten AT shillest.net, ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a6fae9ff0..60dbd0c34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.283 2005/08/09 17:09:54 tim Exp $ 1# $Id: configure.ac,v 1.284 2005/08/10 10:34:15 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -1023,6 +1023,20 @@ AC_ARG_WITH(libedit,
1023 [ AC_MSG_ERROR(libedit not found) ], 1023 [ AC_MSG_ERROR(libedit not found) ],
1024 [ -lcurses ] 1024 [ -lcurses ]
1025 ) 1025 )
1026 AC_MSG_CHECKING(if libedit version is compatible)
1027 AC_TRY_COMPILE([#include <histedit.h>],
1028 [
1029int main(void)
1030{
1031 int i = H_SETSIZE;
1032 el_init("", NULL, NULL, NULL);
1033 exit(0);
1034}
1035 ],
1036 [ AC_MSG_RESULT(yes) ],
1037 [ AC_MSG_RESULT(no)
1038 AC_MSG_ERROR(libedit version is not compatible) ]
1039 )
1026 fi ] 1040 fi ]
1027) 1041)
1028 1042