summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2018-02-25 23:55:41 +1100
committerDarren Tucker <dtucker@dtucker.net>2018-02-26 00:14:42 +1100
commitc7b5a47e3b9db9a0f0198f9c90c705f6307afc2b (patch)
treef0b486ac5bb76056b06d55eff3dd37e7d503a697 /configure.ac
parentb39593a6de5290650a01adf8699c6460570403c2 (diff)
Invert sense of getpgrp test.
AC_FUNC_GETPGRP tests if getpgrp(0) works, which it does if it's not declared. Instead, test if the zero-arg version we want to use works.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f96c70bcd..d3deac832 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1736,7 +1736,6 @@ AC_CHECK_FUNCS([ \
1736 getpeereid \ 1736 getpeereid \
1737 getpeerucred \ 1737 getpeerucred \
1738 getpgid \ 1738 getpgid \
1739 getpgrp \
1740 _getpty \ 1739 _getpty \
1741 getrlimit \ 1740 getrlimit \
1742 getsid \ 1741 getsid \
@@ -2413,7 +2412,16 @@ static void sighandler(int sig) { _exit(1); }
2413 ) 2412 )
2414fi 2413fi
2415 2414
2416AC_FUNC_GETPGRP 2415AC_CHECK_FUNCS([getpgrp],[
2416 AC_MSG_CHECKING([if getpgrp accepts zero args])
2417 AC_COMPILE_IFELSE(
2418 [AC_LANG_PROGRAM([[$ac_includes_default]], [[ getpgrp(); ]])],
2419 [ AC_MSG_RESULT([yes])
2420 AC_DEFINE([GETPGRP_VOID], [1], [getpgrp takes zero args])],
2421 [ AC_MSG_RESULT([no])
2422 AC_DEFINE([GETPGRP_VOID], [0], [getpgrp takes one arg])]
2423 )
2424])
2417 2425
2418# Search for OpenSSL 2426# Search for OpenSSL
2419saved_CPPFLAGS="$CPPFLAGS" 2427saved_CPPFLAGS="$CPPFLAGS"