summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2016-08-01 14:31:52 -0700
committerTim Rice <tim@multitalents.net>2016-08-01 14:31:52 -0700
commitcf3e0be7f5828a5e5f6c296a607d20be2f07d60c (patch)
tree01964a9c47f5e31a9f74c8e0f0868c428e2249b8 /configure.ac
parent99522ba7ec6963a05c04a156bf20e3ba3605987c (diff)
modified: configure.ac opensshd.init.in
Skip generating missing RSA1 key on startup unless ssh1 support is enabled. Spotted by Jean-Pierre Radley
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 373d21b34..7c1956dc6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,6 +123,7 @@ AC_CHECK_DECL([PR_SET_NO_NEW_PRIVS], [have_linux_no_new_privs=1], , [
123 123
124openssl=yes 124openssl=yes
125ssh1=no 125ssh1=no
126COMMENT_OUT_RSA1="#no ssh1#"
126AC_ARG_WITH([openssl], 127AC_ARG_WITH([openssl],
127 [ --without-openssl Disable use of OpenSSL; use only limited internal crypto **EXPERIMENTAL** ], 128 [ --without-openssl Disable use of OpenSSL; use only limited internal crypto **EXPERIMENTAL** ],
128 [ if test "x$withval" = "xno" ; then 129 [ if test "x$withval" = "xno" ; then
@@ -147,6 +148,7 @@ AC_ARG_WITH([ssh1],
147 AC_MSG_ERROR([Cannot enable SSH protocol 1 with OpenSSL disabled]) 148 AC_MSG_ERROR([Cannot enable SSH protocol 1 with OpenSSL disabled])
148 fi 149 fi
149 ssh1=yes 150 ssh1=yes
151 COMMENT_OUT_RSA1=""
150 elif test "x$withval" = "xno" ; then 152 elif test "x$withval" = "xno" ; then
151 ssh1=no 153 ssh1=no
152 else 154 else
@@ -158,6 +160,7 @@ AC_MSG_CHECKING([whether SSH protocol 1 support is enabled])
158if test "x$ssh1" = "xyes" ; then 160if test "x$ssh1" = "xyes" ; then
159 AC_MSG_RESULT([yes]) 161 AC_MSG_RESULT([yes])
160 AC_DEFINE_UNQUOTED([WITH_SSH1], [1], [include SSH protocol version 1 support]) 162 AC_DEFINE_UNQUOTED([WITH_SSH1], [1], [include SSH protocol version 1 support])
163 AC_SUBST([COMMENT_OUT_RSA1])
161else 164else
162 AC_MSG_RESULT([no]) 165 AC_MSG_RESULT([no])
163fi 166fi