summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2013-01-09 16:42:47 +1100
committerDamien Miller <djm@mindrot.org>2013-01-09 16:42:47 +1100
commitd522c68872689e2e80d9667da1c9a18d04b001cd (patch)
tree418d206dc74252baf58aa08b6ce27d789f476378 /configure.ac
parent1d75abfe23cadf8cdba0bd2cfd54f3bc1ca80dc5 (diff)
- (djm) [cipher.c configure.ac openbsd-compat/openssl-compat.h]
Fix merge botch, automatically detect AES-GCM in OpenSSL, move a little cipher compat code to openssl-compat.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 22 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 64c231b7e..36761233c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.499 2012/12/12 21:18:56 djm Exp $ 1# $Id: configure.ac,v 1.500 2013/01/09 05:42:47 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.499 $) 18AC_REVISION($Revision: 1.500 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -2320,6 +2320,26 @@ AC_LINK_IFELSE(
2320 ] 2320 ]
2321) 2321)
2322 2322
2323# Check for OpenSSL with EVP_aes_*gcm
2324AC_MSG_CHECKING([whether OpenSSL has AES GCM via EVP])
2325AC_LINK_IFELSE(
2326 [AC_LANG_PROGRAM([[
2327#include <string.h>
2328#include <openssl/evp.h>
2329 ]], [[
2330 exit(EVP_aes_128_gcm() == NULL ||
2331 EVP_aes_256_gcm() == NULL);
2332 ]])],
2333 [
2334 AC_MSG_RESULT([yes])
2335 AC_DEFINE([OPENSSL_HAVE_EVPGCM], [1],
2336 [libcrypto has EVP AES GCM])
2337 ],
2338 [
2339 AC_MSG_RESULT([no])
2340 ]
2341)
2342
2323AC_MSG_CHECKING([if EVP_DigestUpdate returns an int]) 2343AC_MSG_CHECKING([if EVP_DigestUpdate returns an int])
2324AC_LINK_IFELSE( 2344AC_LINK_IFELSE(
2325 [AC_LANG_PROGRAM([[ 2345 [AC_LANG_PROGRAM([[