summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2009-09-01 18:26:00 +1000
committerDarren Tucker <dtucker@zip.com.au>2009-09-01 18:26:00 +1000
commitdad48e7a96385f8a1bdadd9196e00cefa2a9b702 (patch)
tree5a8f9b5d5245a512cafc258ea06e0baca9bf20c6 /configure.ac
parent427adf1538d3e6e3c2ec059c52fa116942bf334a (diff)
- (dtucker) [configure.ac] Bug #1639: use AC_PATH_PROG to search the path for
krb5-config if it's not in the location specified by --with-kerberos5. Patch from jchadima at redhat.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 00aefac23..a0b781ee4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.425 2009/08/28 05:01:20 dtucker Exp $ 1# $Id: configure.ac,v 1.426 2009/09/01 08:26:00 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.425 $) 18AC_REVISION($Revision: 1.426 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -3404,10 +3404,10 @@ AC_ARG_WITH(kerberos5,
3404 AC_DEFINE(KRB5, 1, [Define if you want Kerberos 5 support]) 3404 AC_DEFINE(KRB5, 1, [Define if you want Kerberos 5 support])
3405 KRB5_MSG="yes" 3405 KRB5_MSG="yes"
3406 3406
3407 AC_MSG_CHECKING(for krb5-config) 3407 AC_PATH_PROG([KRB5CONF],[krb5-config],
3408 if test -x $KRB5ROOT/bin/krb5-config ; then 3408 [$KRB5ROOT/bin/krb5-config],
3409 KRB5CONF=$KRB5ROOT/bin/krb5-config 3409 [$KRB5ROOT/bin:$PATH])
3410 AC_MSG_RESULT($KRB5CONF) 3410 if test -x $KRB5CONF ; then
3411 3411
3412 AC_MSG_CHECKING(for gssapi support) 3412 AC_MSG_CHECKING(for gssapi support)
3413 if $KRB5CONF | grep gssapi >/dev/null ; then 3413 if $KRB5CONF | grep gssapi >/dev/null ; then
@@ -3433,7 +3433,6 @@ AC_ARG_WITH(kerberos5,
3433 AC_MSG_RESULT(no) 3433 AC_MSG_RESULT(no)
3434 ) 3434 )
3435 else 3435 else
3436 AC_MSG_RESULT(no)
3437 CPPFLAGS="$CPPFLAGS -I${KRB5ROOT}/include" 3436 CPPFLAGS="$CPPFLAGS -I${KRB5ROOT}/include"
3438 LDFLAGS="$LDFLAGS -L${KRB5ROOT}/lib" 3437 LDFLAGS="$LDFLAGS -L${KRB5ROOT}/lib"
3439 AC_MSG_CHECKING(whether we are using Heimdal) 3438 AC_MSG_CHECKING(whether we are using Heimdal)