summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2017-05-24 23:21:19 -0400
committerDamien Miller <djm@mindrot.org>2017-05-25 14:34:52 +1000
commitdcc714c65cfb81eb6903095b4590719e8690f3da (patch)
tree363ff3be7fd2cabb2a7501619639eaeae40bc9b6 /configure.ac
parent947a3e829a5b8832a4768fd764283709a4ca7955 (diff)
configure: actually set cache vars when cross-compiling
The cross-compiling fallback message says it's assuming the test passed, but it didn't actually set the cache var which causes later tests to fail.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5cfea38c0..895c5211e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3162,7 +3162,8 @@ AC_RUN_IFELSE(
3162 select_works_with_rlimit=yes], 3162 select_works_with_rlimit=yes],
3163 [AC_MSG_RESULT([no]) 3163 [AC_MSG_RESULT([no])
3164 select_works_with_rlimit=no], 3164 select_works_with_rlimit=no],
3165 [AC_MSG_WARN([cross compiling: assuming yes])] 3165 [AC_MSG_WARN([cross compiling: assuming yes])
3166 select_works_with_rlimit=yes]
3166) 3167)
3167 3168
3168AC_MSG_CHECKING([if setrlimit(RLIMIT_NOFILE,{0,0}) works]) 3169AC_MSG_CHECKING([if setrlimit(RLIMIT_NOFILE,{0,0}) works])
@@ -3188,7 +3189,8 @@ AC_RUN_IFELSE(
3188 rlimit_nofile_zero_works=yes], 3189 rlimit_nofile_zero_works=yes],
3189 [AC_MSG_RESULT([no]) 3190 [AC_MSG_RESULT([no])
3190 rlimit_nofile_zero_works=no], 3191 rlimit_nofile_zero_works=no],
3191 [AC_MSG_WARN([cross compiling: assuming yes])] 3192 [AC_MSG_WARN([cross compiling: assuming yes])
3193 rlimit_nofile_zero_works=yes]
3192) 3194)
3193 3195
3194AC_MSG_CHECKING([if setrlimit RLIMIT_FSIZE works]) 3196AC_MSG_CHECKING([if setrlimit RLIMIT_FSIZE works])