summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2018-02-13 09:10:46 +1100
committerDarren Tucker <dtucker@dtucker.net>2018-02-15 20:04:02 +1100
commitddc0f3814881ea279a6b6d4d98e03afc60ae1ed7 (patch)
treed09efd846cd29f2dfeb0acd04756294e4f6761c9 /configure.ac
parent174bed686968494723e6db881208cc4dac0d020f (diff)
Remove UNICOS support.
The code required to support it is quite invasive to the mainline code that is synced with upstream and is an ongoing maintenance burden. Both the hardware and software are literal museum pieces these days and we could not find anyone still running OpenSSH on one.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 0 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index 753395f10..38600e321 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1073,40 +1073,6 @@ mips-sony-bsd|mips-sony-newsos4)
1073 TEST_SHELL=$SHELL # let configure find us a capable shell 1073 TEST_SHELL=$SHELL # let configure find us a capable shell
1074 SKIP_DISABLE_LASTLOG_DEFINE=yes 1074 SKIP_DISABLE_LASTLOG_DEFINE=yes
1075 ;; 1075 ;;
1076*-*-unicosmk*)
1077 AC_DEFINE([NO_SSH_LASTLOG], [1],
1078 [Define if you don't want to use lastlog in session.c])
1079 AC_DEFINE([SETEUID_BREAKS_SETUID])
1080 AC_DEFINE([BROKEN_SETREUID])
1081 AC_DEFINE([BROKEN_SETREGID])
1082 AC_DEFINE([USE_PIPES])
1083 AC_DEFINE([DISABLE_FD_PASSING])
1084 LDFLAGS="$LDFLAGS"
1085 LIBS="$LIBS -lgen -lrsc -lshare -luex -lacm"
1086 MANTYPE=cat
1087 ;;
1088*-*-unicosmp*)
1089 AC_DEFINE([SETEUID_BREAKS_SETUID])
1090 AC_DEFINE([BROKEN_SETREUID])
1091 AC_DEFINE([BROKEN_SETREGID])
1092 AC_DEFINE([WITH_ABBREV_NO_TTY])
1093 AC_DEFINE([USE_PIPES])
1094 AC_DEFINE([DISABLE_FD_PASSING])
1095 LDFLAGS="$LDFLAGS"
1096 LIBS="$LIBS -lgen -lacid -ldb"
1097 MANTYPE=cat
1098 ;;
1099*-*-unicos*)
1100 AC_DEFINE([SETEUID_BREAKS_SETUID])
1101 AC_DEFINE([BROKEN_SETREUID])
1102 AC_DEFINE([BROKEN_SETREGID])
1103 AC_DEFINE([USE_PIPES])
1104 AC_DEFINE([DISABLE_FD_PASSING])
1105 AC_DEFINE([NO_SSH_LASTLOG])
1106 LDFLAGS="$LDFLAGS -Wl,-Dmsglevel=334:fatal"
1107 LIBS="$LIBS -lgen -lrsc -lshare -luex -lacm"
1108 MANTYPE=cat
1109 ;;
1110*-dec-osf*) 1076*-dec-osf*)
1111 AC_MSG_CHECKING([for Digital Unix SIA]) 1077 AC_MSG_CHECKING([for Digital Unix SIA])
1112 no_osfsia="" 1078 no_osfsia=""