summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2005-05-26 20:48:25 +1000
committerDamien Miller <djm@mindrot.org>2005-05-26 20:48:25 +1000
commitde3cb0a3dc1bd98762afa3d71f3ffcdb76029fad (patch)
tree8c0729f879a4458a36ef691480c553382ac2775a /configure.ac
parent84ce9b455d04e7f145d43ef8dac2ddc59e41802d (diff)
- (djm) [configure.ac openbsd-compat/Makefile.in]
[openbsd-compat/openbsd-compat.h openbsd-compat/strtonum.c] Add strtonum(3) from OpenBSD libc, new code needs it. Unfortunately Linux forces us to do a bizarre dance with compiler options to get LLONG_MIN/MAX; Spotted by and ok dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fd8218aea..58a3ff47d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.261 2005/05/26 10:12:15 dtucker Exp $ 1# $Id: configure.ac,v 1.262 2005/05/26 10:48:25 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -79,6 +79,15 @@ AC_SUBST(LD)
79AC_C_INLINE 79AC_C_INLINE
80if test "$GCC" = "yes" || test "$GCC" = "egcs"; then 80if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
81 CFLAGS="$CFLAGS -Wall -Wpointer-arith -Wno-uninitialized" 81 CFLAGS="$CFLAGS -Wall -Wpointer-arith -Wno-uninitialized"
82
83 # Check for -std=gnu99 support (needed for LLONG_MIN/MAX on Linux)
84 saved_CFLAGS="$CFLAGS"
85 CFLAGS="$CFLAGS -std=gnu99"
86 AC_MSG_CHECKING(whether cc accepts -std=gnu99 option)
87 AC_TRY_COMPILE([], [return(0);], [AC_MSG_RESULT(yes)],
88 [AC_MSG_RESULT(no)
89 CFLAGS="$saved_CFLAGS"],
90 )
82fi 91fi
83 92
84AC_ARG_WITH(rpath, 93AC_ARG_WITH(rpath,
@@ -922,7 +931,7 @@ AC_CHECK_FUNCS(\
922 setdtablesize setegid setenv seteuid setgroups setlogin setpcred \ 931 setdtablesize setegid setenv seteuid setgroups setlogin setpcred \
923 setproctitle setregid setreuid setrlimit \ 932 setproctitle setregid setreuid setrlimit \
924 setsid setvbuf sigaction sigvec snprintf socketpair strerror \ 933 setsid setvbuf sigaction sigvec snprintf socketpair strerror \
925 strlcat strlcpy strmode strnvis strtoul sysconf tcgetpgrp \ 934 strlcat strlcpy strmode strnvis strtonum strtoul sysconf tcgetpgrp \
926 truncate unsetenv updwtmpx utimes vhangup vsnprintf waitpid \ 935 truncate unsetenv updwtmpx utimes vhangup vsnprintf waitpid \
927) 936)
928 937