summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2016-05-31 11:13:22 -0700
committerTim Rice <tim@multitalents.net>2016-05-31 11:13:22 -0700
commite1d93705f8f48f519433d6ca9fc3d0abe92a1b77 (patch)
treee9c95cd917d25dc45368ceaba826e5bbe2526a4f /configure.ac
parent604a037d84e41e31f0aec9075df0b8740c130200 (diff)
modified: configure.ac
whitspace clean up. No code changes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac95
1 files changed, 47 insertions, 48 deletions
diff --git a/configure.ac b/configure.ac
index dde3c4589..663870381 100644
--- a/configure.ac
+++ b/configure.ac
@@ -632,7 +632,7 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
632 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 632 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
633 [Prepend the address family to IP tunnel traffic]) 633 [Prepend the address family to IP tunnel traffic])
634 m4_pattern_allow([AU_IPv]) 634 m4_pattern_allow([AU_IPv])
635 AC_CHECK_DECL([AU_IPv4], [], 635 AC_CHECK_DECL([AU_IPv4], [],
636 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 636 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])
637 [#include <bsm/audit.h>] 637 [#include <bsm/audit.h>]
638 AC_DEFINE([LASTLOG_WRITE_PUTUTXLINE], [1], 638 AC_DEFINE([LASTLOG_WRITE_PUTUTXLINE], [1],
@@ -651,12 +651,12 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
651 SSHDLIBS="$SSHDLIBS -lcrypt" 651 SSHDLIBS="$SSHDLIBS -lcrypt"
652 TEST_MALLOC_OPTIONS="AFGJPRX" 652 TEST_MALLOC_OPTIONS="AFGJPRX"
653 ;; 653 ;;
654*-*-haiku*) 654*-*-haiku*)
655 LIBS="$LIBS -lbsd " 655 LIBS="$LIBS -lbsd "
656 AC_CHECK_LIB([network], [socket]) 656 AC_CHECK_LIB([network], [socket])
657 AC_DEFINE([HAVE_U_INT64_T]) 657 AC_DEFINE([HAVE_U_INT64_T])
658 MANTYPE=man 658 MANTYPE=man
659 ;; 659 ;;
660*-*-hpux*) 660*-*-hpux*)
661 # first we define all of the options common to all HP-UX releases 661 # first we define all of the options common to all HP-UX releases
662 CPPFLAGS="$CPPFLAGS -D_HPUX_SOURCE -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED=1" 662 CPPFLAGS="$CPPFLAGS -D_HPUX_SOURCE -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED=1"
@@ -1437,7 +1437,7 @@ AC_ARG_WITH([skey],
1437 AC_MSG_RESULT([no]) 1437 AC_MSG_RESULT([no])
1438 AC_MSG_ERROR([** Incomplete or missing s/key libraries.]) 1438 AC_MSG_ERROR([** Incomplete or missing s/key libraries.])
1439 ]) 1439 ])
1440 AC_MSG_CHECKING([if skeychallenge takes 4 arguments]) 1440 AC_MSG_CHECKING([if skeychallenge takes 4 arguments])
1441 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ 1441 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
1442#include <stdio.h> 1442#include <stdio.h>
1443#include <skey.h> 1443#include <skey.h>
@@ -1500,7 +1500,7 @@ AC_ARG_WITH([libedit],
1500 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no]) 1500 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
1501 if test "x$PKGCONFIG" != "xno"; then 1501 if test "x$PKGCONFIG" != "xno"; then
1502 AC_MSG_CHECKING([if $PKGCONFIG knows about libedit]) 1502 AC_MSG_CHECKING([if $PKGCONFIG knows about libedit])
1503 if "$PKGCONFIG" libedit; then 1503 if "$PKGCONFIG" libedit; then
1504 AC_MSG_RESULT([yes]) 1504 AC_MSG_RESULT([yes])
1505 use_pkgconfig_for_libedit=yes 1505 use_pkgconfig_for_libedit=yes
1506 else 1506 else
@@ -1571,9 +1571,9 @@ AC_ARG_WITH([audit],
1571 AC_CHECK_FUNCS([getaudit_addr aug_get_machine]) 1571 AC_CHECK_FUNCS([getaudit_addr aug_get_machine])
1572 AC_DEFINE([USE_BSM_AUDIT], [1], [Use BSM audit module]) 1572 AC_DEFINE([USE_BSM_AUDIT], [1], [Use BSM audit module])
1573 if test "$sol2ver" -ge 11; then 1573 if test "$sol2ver" -ge 11; then
1574 SSHDLIBS="$SSHDLIBS -lscf" 1574 SSHDLIBS="$SSHDLIBS -lscf"
1575 AC_DEFINE([BROKEN_BSM_API], [1], 1575 AC_DEFINE([BROKEN_BSM_API], [1],
1576 [The system has incomplete BSM API]) 1576 [The system has incomplete BSM API])
1577 fi 1577 fi
1578 ;; 1578 ;;
1579 linux) 1579 linux)
@@ -1981,7 +1981,7 @@ if test "x$ac_cv_func_snprintf" = "xyes" ; then
1981 [[ 1981 [[
1982 char b[5]; 1982 char b[5];
1983 snprintf(b,5,"123456789"); 1983 snprintf(b,5,"123456789");
1984 exit(b[4]!='\0'); 1984 exit(b[4]!='\0');
1985 ]])], 1985 ]])],
1986 [AC_MSG_RESULT([yes])], 1986 [AC_MSG_RESULT([yes])],
1987 [ 1987 [
@@ -2796,7 +2796,7 @@ AC_CHECK_LIB([iaf], [ia_openinfo], [
2796 LIBS="$LIBS -liaf" 2796 LIBS="$LIBS -liaf"
2797 AC_CHECK_FUNCS([set_id], [SSHDLIBS="$SSHDLIBS -liaf" 2797 AC_CHECK_FUNCS([set_id], [SSHDLIBS="$SSHDLIBS -liaf"
2798 AC_DEFINE([HAVE_LIBIAF], [1], 2798 AC_DEFINE([HAVE_LIBIAF], [1],
2799 [Define if system has libiaf that supports set_id]) 2799 [Define if system has libiaf that supports set_id])
2800 ]) 2800 ])
2801]) 2801])
2802LIBS="$saved_LIBS" 2802LIBS="$saved_LIBS"
@@ -3322,7 +3322,7 @@ fi
3322AC_CACHE_CHECK([for u_int type], ac_cv_have_u_int, [ 3322AC_CACHE_CHECK([for u_int type], ac_cv_have_u_int, [
3323 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]], 3323 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]],
3324 [[ u_int a; a = 1;]])], 3324 [[ u_int a; a = 1;]])],
3325 [ ac_cv_have_u_int="yes" ], [ ac_cv_have_u_int="no" 3325 [ ac_cv_have_u_int="yes" ], [ ac_cv_have_u_int="no"
3326 ]) 3326 ])
3327]) 3327])
3328if test "x$ac_cv_have_u_int" = "xyes" ; then 3328if test "x$ac_cv_have_u_int" = "xyes" ; then
@@ -3333,7 +3333,7 @@ fi
3333AC_CACHE_CHECK([for intXX_t types], ac_cv_have_intxx_t, [ 3333AC_CACHE_CHECK([for intXX_t types], ac_cv_have_intxx_t, [
3334 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]], 3334 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]],
3335 [[ int8_t a; int16_t b; int32_t c; a = b = c = 1;]])], 3335 [[ int8_t a; int16_t b; int32_t c; a = b = c = 1;]])],
3336 [ ac_cv_have_intxx_t="yes" ], [ ac_cv_have_intxx_t="no" 3336 [ ac_cv_have_intxx_t="yes" ], [ ac_cv_have_intxx_t="no"
3337 ]) 3337 ])
3338]) 3338])
3339if test "x$ac_cv_have_intxx_t" = "xyes" ; then 3339if test "x$ac_cv_have_intxx_t" = "xyes" ; then
@@ -3350,7 +3350,7 @@ then
3350 [ 3350 [
3351 AC_DEFINE([HAVE_INTXX_T]) 3351 AC_DEFINE([HAVE_INTXX_T])
3352 AC_MSG_RESULT([yes]) 3352 AC_MSG_RESULT([yes])
3353 ], [ AC_MSG_RESULT([no]) 3353 ], [ AC_MSG_RESULT([no])
3354 ]) 3354 ])
3355fi 3355fi
3356 3356
@@ -3367,7 +3367,7 @@ AC_CACHE_CHECK([for int64_t type], ac_cv_have_int64_t, [
3367 ]], [[ 3367 ]], [[
3368int64_t a; a = 1; 3368int64_t a; a = 1;
3369 ]])], 3369 ]])],
3370 [ ac_cv_have_int64_t="yes" ], [ ac_cv_have_int64_t="no" 3370 [ ac_cv_have_int64_t="yes" ], [ ac_cv_have_int64_t="no"
3371 ]) 3371 ])
3372]) 3372])
3373if test "x$ac_cv_have_int64_t" = "xyes" ; then 3373if test "x$ac_cv_have_int64_t" = "xyes" ; then
@@ -3377,7 +3377,7 @@ fi
3377AC_CACHE_CHECK([for u_intXX_t types], ac_cv_have_u_intxx_t, [ 3377AC_CACHE_CHECK([for u_intXX_t types], ac_cv_have_u_intxx_t, [
3378 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]], 3378 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]],
3379 [[ u_int8_t a; u_int16_t b; u_int32_t c; a = b = c = 1;]])], 3379 [[ u_int8_t a; u_int16_t b; u_int32_t c; a = b = c = 1;]])],
3380 [ ac_cv_have_u_intxx_t="yes" ], [ ac_cv_have_u_intxx_t="no" 3380 [ ac_cv_have_u_intxx_t="yes" ], [ ac_cv_have_u_intxx_t="no"
3381 ]) 3381 ])
3382]) 3382])
3383if test "x$ac_cv_have_u_intxx_t" = "xyes" ; then 3383if test "x$ac_cv_have_u_intxx_t" = "xyes" ; then
@@ -3392,14 +3392,14 @@ if test -z "$have_u_intxx_t" ; then
3392 [ 3392 [
3393 AC_DEFINE([HAVE_U_INTXX_T]) 3393 AC_DEFINE([HAVE_U_INTXX_T])
3394 AC_MSG_RESULT([yes]) 3394 AC_MSG_RESULT([yes])
3395 ], [ AC_MSG_RESULT([no]) 3395 ], [ AC_MSG_RESULT([no])
3396 ]) 3396 ])
3397fi 3397fi
3398 3398
3399AC_CACHE_CHECK([for u_int64_t types], ac_cv_have_u_int64_t, [ 3399AC_CACHE_CHECK([for u_int64_t types], ac_cv_have_u_int64_t, [
3400 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]], 3400 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]],
3401 [[ u_int64_t a; a = 1;]])], 3401 [[ u_int64_t a; a = 1;]])],
3402 [ ac_cv_have_u_int64_t="yes" ], [ ac_cv_have_u_int64_t="no" 3402 [ ac_cv_have_u_int64_t="yes" ], [ ac_cv_have_u_int64_t="no"
3403 ]) 3403 ])
3404]) 3404])
3405if test "x$ac_cv_have_u_int64_t" = "xyes" ; then 3405if test "x$ac_cv_have_u_int64_t" = "xyes" ; then
@@ -3416,7 +3416,7 @@ then
3416 [ 3416 [
3417 AC_DEFINE([HAVE_U_INT64_T]) 3417 AC_DEFINE([HAVE_U_INT64_T])
3418 AC_MSG_RESULT([yes]) 3418 AC_MSG_RESULT([yes])
3419 ], [ AC_MSG_RESULT([no]) 3419 ], [ AC_MSG_RESULT([no])
3420 ]) 3420 ])
3421fi 3421fi
3422 3422
@@ -3430,7 +3430,7 @@ if test -z "$have_u_intxx_t" ; then
3430 uint32_t c; 3430 uint32_t c;
3431 a = b = c = 1; 3431 a = b = c = 1;
3432 ]])], 3432 ]])],
3433 [ ac_cv_have_uintxx_t="yes" ], [ ac_cv_have_uintxx_t="no" 3433 [ ac_cv_have_uintxx_t="yes" ], [ ac_cv_have_uintxx_t="no"
3434 ]) 3434 ])
3435 ]) 3435 ])
3436 if test "x$ac_cv_have_uintxx_t" = "xyes" ; then 3436 if test "x$ac_cv_have_uintxx_t" = "xyes" ; then
@@ -3448,7 +3448,7 @@ then
3448 [ 3448 [
3449 AC_DEFINE([HAVE_UINTXX_T]) 3449 AC_DEFINE([HAVE_UINTXX_T])
3450 AC_MSG_RESULT([yes]) 3450 AC_MSG_RESULT([yes])
3451 ], [ AC_MSG_RESULT([no]) 3451 ], [ AC_MSG_RESULT([no])
3452 ]) 3452 ])
3453fi 3453fi
3454 3454
@@ -3461,7 +3461,7 @@ then
3461 [ 3461 [
3462 AC_DEFINE([HAVE_UINTXX_T]) 3462 AC_DEFINE([HAVE_UINTXX_T])
3463 AC_MSG_RESULT([yes]) 3463 AC_MSG_RESULT([yes])
3464 ], [ AC_MSG_RESULT([no]) 3464 ], [ AC_MSG_RESULT([no])
3465 ]) 3465 ])
3466fi 3466fi
3467 3467
@@ -3488,7 +3488,7 @@ fi
3488AC_CACHE_CHECK([for u_char], ac_cv_have_u_char, [ 3488AC_CACHE_CHECK([for u_char], ac_cv_have_u_char, [
3489 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]], 3489 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]],
3490 [[ u_char foo; foo = 125; ]])], 3490 [[ u_char foo; foo = 125; ]])],
3491 [ ac_cv_have_u_char="yes" ], [ ac_cv_have_u_char="no" 3491 [ ac_cv_have_u_char="yes" ], [ ac_cv_have_u_char="no"
3492 ]) 3492 ])
3493]) 3493])
3494if test "x$ac_cv_have_u_char" = "xyes" ; then 3494if test "x$ac_cv_have_u_char" = "xyes" ; then
@@ -3523,7 +3523,7 @@ AC_CHECK_TYPES([in_addr_t, in_port_t], , ,
3523AC_CACHE_CHECK([for size_t], ac_cv_have_size_t, [ 3523AC_CACHE_CHECK([for size_t], ac_cv_have_size_t, [
3524 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]], 3524 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]],
3525 [[ size_t foo; foo = 1235; ]])], 3525 [[ size_t foo; foo = 1235; ]])],
3526 [ ac_cv_have_size_t="yes" ], [ ac_cv_have_size_t="no" 3526 [ ac_cv_have_size_t="yes" ], [ ac_cv_have_size_t="no"
3527 ]) 3527 ])
3528]) 3528])
3529if test "x$ac_cv_have_size_t" = "xyes" ; then 3529if test "x$ac_cv_have_size_t" = "xyes" ; then
@@ -3533,7 +3533,7 @@ fi
3533AC_CACHE_CHECK([for ssize_t], ac_cv_have_ssize_t, [ 3533AC_CACHE_CHECK([for ssize_t], ac_cv_have_ssize_t, [
3534 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]], 3534 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]],
3535 [[ ssize_t foo; foo = 1235; ]])], 3535 [[ ssize_t foo; foo = 1235; ]])],
3536 [ ac_cv_have_ssize_t="yes" ], [ ac_cv_have_ssize_t="no" 3536 [ ac_cv_have_ssize_t="yes" ], [ ac_cv_have_ssize_t="no"
3537 ]) 3537 ])
3538]) 3538])
3539if test "x$ac_cv_have_ssize_t" = "xyes" ; then 3539if test "x$ac_cv_have_ssize_t" = "xyes" ; then
@@ -3543,7 +3543,7 @@ fi
3543AC_CACHE_CHECK([for clock_t], ac_cv_have_clock_t, [ 3543AC_CACHE_CHECK([for clock_t], ac_cv_have_clock_t, [
3544 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <time.h> ]], 3544 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <time.h> ]],
3545 [[ clock_t foo; foo = 1235; ]])], 3545 [[ clock_t foo; foo = 1235; ]])],
3546 [ ac_cv_have_clock_t="yes" ], [ ac_cv_have_clock_t="no" 3546 [ ac_cv_have_clock_t="yes" ], [ ac_cv_have_clock_t="no"
3547 ]) 3547 ])
3548]) 3548])
3549if test "x$ac_cv_have_clock_t" = "xyes" ; then 3549if test "x$ac_cv_have_clock_t" = "xyes" ; then
@@ -3574,7 +3574,7 @@ fi
3574AC_CACHE_CHECK([for pid_t], ac_cv_have_pid_t, [ 3574AC_CACHE_CHECK([for pid_t], ac_cv_have_pid_t, [
3575 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]], 3575 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]],
3576 [[ pid_t foo; foo = 1235; ]])], 3576 [[ pid_t foo; foo = 1235; ]])],
3577 [ ac_cv_have_pid_t="yes" ], [ ac_cv_have_pid_t="no" 3577 [ ac_cv_have_pid_t="yes" ], [ ac_cv_have_pid_t="no"
3578 ]) 3578 ])
3579]) 3579])
3580if test "x$ac_cv_have_pid_t" = "xyes" ; then 3580if test "x$ac_cv_have_pid_t" = "xyes" ; then
@@ -3584,7 +3584,7 @@ fi
3584AC_CACHE_CHECK([for mode_t], ac_cv_have_mode_t, [ 3584AC_CACHE_CHECK([for mode_t], ac_cv_have_mode_t, [
3585 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]], 3585 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h> ]],
3586 [[ mode_t foo; foo = 1235; ]])], 3586 [[ mode_t foo; foo = 1235; ]])],
3587 [ ac_cv_have_mode_t="yes" ], [ ac_cv_have_mode_t="no" 3587 [ ac_cv_have_mode_t="yes" ], [ ac_cv_have_mode_t="no"
3588 ]) 3588 ])
3589]) 3589])
3590if test "x$ac_cv_have_mode_t" = "xyes" ; then 3590if test "x$ac_cv_have_mode_t" = "xyes" ; then
@@ -3598,7 +3598,7 @@ AC_CACHE_CHECK([for struct sockaddr_storage], ac_cv_have_struct_sockaddr_storage
3598#include <sys/socket.h> 3598#include <sys/socket.h>
3599 ]], [[ struct sockaddr_storage s; ]])], 3599 ]], [[ struct sockaddr_storage s; ]])],
3600 [ ac_cv_have_struct_sockaddr_storage="yes" ], 3600 [ ac_cv_have_struct_sockaddr_storage="yes" ],
3601 [ ac_cv_have_struct_sockaddr_storage="no" 3601 [ ac_cv_have_struct_sockaddr_storage="no"
3602 ]) 3602 ])
3603]) 3603])
3604if test "x$ac_cv_have_struct_sockaddr_storage" = "xyes" ; then 3604if test "x$ac_cv_have_struct_sockaddr_storage" = "xyes" ; then
@@ -3612,7 +3612,7 @@ AC_CACHE_CHECK([for struct sockaddr_in6], ac_cv_have_struct_sockaddr_in6, [
3612#include <netinet/in.h> 3612#include <netinet/in.h>
3613 ]], [[ struct sockaddr_in6 s; s.sin6_family = 0; ]])], 3613 ]], [[ struct sockaddr_in6 s; s.sin6_family = 0; ]])],
3614 [ ac_cv_have_struct_sockaddr_in6="yes" ], 3614 [ ac_cv_have_struct_sockaddr_in6="yes" ],
3615 [ ac_cv_have_struct_sockaddr_in6="no" 3615 [ ac_cv_have_struct_sockaddr_in6="no"
3616 ]) 3616 ])
3617]) 3617])
3618if test "x$ac_cv_have_struct_sockaddr_in6" = "xyes" ; then 3618if test "x$ac_cv_have_struct_sockaddr_in6" = "xyes" ; then
@@ -3626,7 +3626,7 @@ AC_CACHE_CHECK([for struct in6_addr], ac_cv_have_struct_in6_addr, [
3626#include <netinet/in.h> 3626#include <netinet/in.h>
3627 ]], [[ struct in6_addr s; s.s6_addr[0] = 0; ]])], 3627 ]], [[ struct in6_addr s; s.s6_addr[0] = 0; ]])],
3628 [ ac_cv_have_struct_in6_addr="yes" ], 3628 [ ac_cv_have_struct_in6_addr="yes" ],
3629 [ ac_cv_have_struct_in6_addr="no" 3629 [ ac_cv_have_struct_in6_addr="no"
3630 ]) 3630 ])
3631]) 3631])
3632if test "x$ac_cv_have_struct_in6_addr" = "xyes" ; then 3632if test "x$ac_cv_have_struct_in6_addr" = "xyes" ; then
@@ -3650,7 +3650,7 @@ AC_CACHE_CHECK([for struct addrinfo], ac_cv_have_struct_addrinfo, [
3650#include <netdb.h> 3650#include <netdb.h>
3651 ]], [[ struct addrinfo s; s.ai_flags = AI_PASSIVE; ]])], 3651 ]], [[ struct addrinfo s; s.ai_flags = AI_PASSIVE; ]])],
3652 [ ac_cv_have_struct_addrinfo="yes" ], 3652 [ ac_cv_have_struct_addrinfo="yes" ],
3653 [ ac_cv_have_struct_addrinfo="no" 3653 [ ac_cv_have_struct_addrinfo="no"
3654 ]) 3654 ])
3655]) 3655])
3656if test "x$ac_cv_have_struct_addrinfo" = "xyes" ; then 3656if test "x$ac_cv_have_struct_addrinfo" = "xyes" ; then
@@ -3662,7 +3662,7 @@ AC_CACHE_CHECK([for struct timeval], ac_cv_have_struct_timeval, [
3662 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/time.h> ]], 3662 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/time.h> ]],
3663 [[ struct timeval tv; tv.tv_sec = 1;]])], 3663 [[ struct timeval tv; tv.tv_sec = 1;]])],
3664 [ ac_cv_have_struct_timeval="yes" ], 3664 [ ac_cv_have_struct_timeval="yes" ],
3665 [ ac_cv_have_struct_timeval="no" 3665 [ ac_cv_have_struct_timeval="no"
3666 ]) 3666 ])
3667]) 3667])
3668if test "x$ac_cv_have_struct_timeval" = "xyes" ; then 3668if test "x$ac_cv_have_struct_timeval" = "xyes" ; then
@@ -3770,7 +3770,7 @@ AC_CACHE_CHECK([for __ss_family field in struct sockaddr_storage],
3770#include <sys/socket.h> 3770#include <sys/socket.h>
3771 ]], [[ struct sockaddr_storage s; s.__ss_family = 1; ]])], 3771 ]], [[ struct sockaddr_storage s; s.__ss_family = 1; ]])],
3772 [ ac_cv_have___ss_family_in_struct_ss="yes" ], 3772 [ ac_cv_have___ss_family_in_struct_ss="yes" ],
3773 [ ac_cv_have___ss_family_in_struct_ss="no" 3773 [ ac_cv_have___ss_family_in_struct_ss="no"
3774 ]) 3774 ])
3775]) 3775])
3776if test "x$ac_cv_have___ss_family_in_struct_ss" = "xyes" ; then 3776if test "x$ac_cv_have___ss_family_in_struct_ss" = "xyes" ; then
@@ -3869,7 +3869,7 @@ AC_CACHE_CHECK([if libc defines __progname], ac_cv_libc_defines___progname, [
3869 AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], 3869 AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
3870 [[ extern char *__progname; printf("%s", __progname); ]])], 3870 [[ extern char *__progname; printf("%s", __progname); ]])],
3871 [ ac_cv_libc_defines___progname="yes" ], 3871 [ ac_cv_libc_defines___progname="yes" ],
3872 [ ac_cv_libc_defines___progname="no" 3872 [ ac_cv_libc_defines___progname="no"
3873 ]) 3873 ])
3874]) 3874])
3875if test "x$ac_cv_libc_defines___progname" = "xyes" ; then 3875if test "x$ac_cv_libc_defines___progname" = "xyes" ; then
@@ -3880,7 +3880,7 @@ AC_CACHE_CHECK([whether $CC implements __FUNCTION__], ac_cv_cc_implements___FUNC
3880 AC_LINK_IFELSE([AC_LANG_PROGRAM([[ #include <stdio.h> ]], 3880 AC_LINK_IFELSE([AC_LANG_PROGRAM([[ #include <stdio.h> ]],
3881 [[ printf("%s", __FUNCTION__); ]])], 3881 [[ printf("%s", __FUNCTION__); ]])],
3882 [ ac_cv_cc_implements___FUNCTION__="yes" ], 3882 [ ac_cv_cc_implements___FUNCTION__="yes" ],
3883 [ ac_cv_cc_implements___FUNCTION__="no" 3883 [ ac_cv_cc_implements___FUNCTION__="no"
3884 ]) 3884 ])
3885]) 3885])
3886if test "x$ac_cv_cc_implements___FUNCTION__" = "xyes" ; then 3886if test "x$ac_cv_cc_implements___FUNCTION__" = "xyes" ; then
@@ -3892,7 +3892,7 @@ AC_CACHE_CHECK([whether $CC implements __func__], ac_cv_cc_implements___func__,
3892 AC_LINK_IFELSE([AC_LANG_PROGRAM([[ #include <stdio.h> ]], 3892 AC_LINK_IFELSE([AC_LANG_PROGRAM([[ #include <stdio.h> ]],
3893 [[ printf("%s", __func__); ]])], 3893 [[ printf("%s", __func__); ]])],
3894 [ ac_cv_cc_implements___func__="yes" ], 3894 [ ac_cv_cc_implements___func__="yes" ],
3895 [ ac_cv_cc_implements___func__="no" 3895 [ ac_cv_cc_implements___func__="no"
3896 ]) 3896 ])
3897]) 3897])
3898if test "x$ac_cv_cc_implements___func__" = "xyes" ; then 3898if test "x$ac_cv_cc_implements___func__" = "xyes" ; then
@@ -3905,7 +3905,7 @@ AC_CACHE_CHECK([whether va_copy exists], ac_cv_have_va_copy, [
3905va_list x,y; 3905va_list x,y;
3906 ]], [[ va_copy(x,y); ]])], 3906 ]], [[ va_copy(x,y); ]])],
3907 [ ac_cv_have_va_copy="yes" ], 3907 [ ac_cv_have_va_copy="yes" ],
3908 [ ac_cv_have_va_copy="no" 3908 [ ac_cv_have_va_copy="no"
3909 ]) 3909 ])
3910]) 3910])
3911if test "x$ac_cv_have_va_copy" = "xyes" ; then 3911if test "x$ac_cv_have_va_copy" = "xyes" ; then
@@ -3917,7 +3917,7 @@ AC_CACHE_CHECK([whether __va_copy exists], ac_cv_have___va_copy, [
3917#include <stdarg.h> 3917#include <stdarg.h>
3918va_list x,y; 3918va_list x,y;
3919 ]], [[ __va_copy(x,y); ]])], 3919 ]], [[ __va_copy(x,y); ]])],
3920 [ ac_cv_have___va_copy="yes" ], [ ac_cv_have___va_copy="no" 3920 [ ac_cv_have___va_copy="yes" ], [ ac_cv_have___va_copy="no"
3921 ]) 3921 ])
3922]) 3922])
3923if test "x$ac_cv_have___va_copy" = "xyes" ; then 3923if test "x$ac_cv_have___va_copy" = "xyes" ; then
@@ -3929,7 +3929,7 @@ AC_CACHE_CHECK([whether getopt has optreset support],
3929 AC_LINK_IFELSE([AC_LANG_PROGRAM([[ #include <getopt.h> ]], 3929 AC_LINK_IFELSE([AC_LANG_PROGRAM([[ #include <getopt.h> ]],
3930 [[ extern int optreset; optreset = 0; ]])], 3930 [[ extern int optreset; optreset = 0; ]])],
3931 [ ac_cv_have_getopt_optreset="yes" ], 3931 [ ac_cv_have_getopt_optreset="yes" ],
3932 [ ac_cv_have_getopt_optreset="no" 3932 [ ac_cv_have_getopt_optreset="no"
3933 ]) 3933 ])
3934]) 3934])
3935if test "x$ac_cv_have_getopt_optreset" = "xyes" ; then 3935if test "x$ac_cv_have_getopt_optreset" = "xyes" ; then
@@ -3941,7 +3941,7 @@ AC_CACHE_CHECK([if libc defines sys_errlist], ac_cv_libc_defines_sys_errlist, [
3941 AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], 3941 AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
3942[[ extern const char *const sys_errlist[]; printf("%s", sys_errlist[0]);]])], 3942[[ extern const char *const sys_errlist[]; printf("%s", sys_errlist[0]);]])],
3943 [ ac_cv_libc_defines_sys_errlist="yes" ], 3943 [ ac_cv_libc_defines_sys_errlist="yes" ],
3944 [ ac_cv_libc_defines_sys_errlist="no" 3944 [ ac_cv_libc_defines_sys_errlist="no"
3945 ]) 3945 ])
3946]) 3946])
3947if test "x$ac_cv_libc_defines_sys_errlist" = "xyes" ; then 3947if test "x$ac_cv_libc_defines_sys_errlist" = "xyes" ; then
@@ -3954,7 +3954,7 @@ AC_CACHE_CHECK([if libc defines sys_nerr], ac_cv_libc_defines_sys_nerr, [
3954 AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], 3954 AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
3955[[ extern int sys_nerr; printf("%i", sys_nerr);]])], 3955[[ extern int sys_nerr; printf("%i", sys_nerr);]])],
3956 [ ac_cv_libc_defines_sys_nerr="yes" ], 3956 [ ac_cv_libc_defines_sys_nerr="yes" ],
3957 [ ac_cv_libc_defines_sys_nerr="no" 3957 [ ac_cv_libc_defines_sys_nerr="no"
3958 ]) 3958 ])
3959]) 3959])
3960if test "x$ac_cv_libc_defines_sys_nerr" = "xyes" ; then 3960if test "x$ac_cv_libc_defines_sys_nerr" = "xyes" ; then
@@ -4113,7 +4113,6 @@ AC_ARG_WITH([kerberos5],
4113 [K5LIBS="$K5LIBS -ldes"]) 4113 [K5LIBS="$K5LIBS -ldes"])
4114 ], [ AC_MSG_RESULT([no]) 4114 ], [ AC_MSG_RESULT([no])
4115 K5LIBS="-lkrb5 -lk5crypto -lcom_err" 4115 K5LIBS="-lkrb5 -lk5crypto -lcom_err"
4116
4117 ]) 4116 ])
4118 AC_SEARCH_LIBS([dn_expand], [resolv]) 4117 AC_SEARCH_LIBS([dn_expand], [resolv])
4119 4118
@@ -4296,7 +4295,7 @@ AC_ARG_WITH([maildir],
4296 exit(0); 4295 exit(0);
4297 ]])], 4296 ]])],
4298 [ 4297 [
4299 maildir_what=`awk -F: '{print $1}' conftest.maildir` 4298 maildir_what=`awk -F: '{print $1}' conftest.maildir`
4300 maildir=`awk -F: '{print $2}' conftest.maildir \ 4299 maildir=`awk -F: '{print $2}' conftest.maildir \
4301 | sed 's|/$||'` 4300 | sed 's|/$||'`
4302 AC_MSG_RESULT([Using: $maildir from $maildir_what]) 4301 AC_MSG_RESULT([Using: $maildir from $maildir_what])
@@ -4641,7 +4640,7 @@ AC_ARG_WITH([pid-dir],
4641 ] 4640 ]
4642) 4641)
4643 4642
4644AC_DEFINE_UNQUOTED([_PATH_SSH_PIDDIR], ["$piddir"], 4643AC_DEFINE_UNQUOTED([_PATH_SSH_PIDDIR], ["$piddir"],
4645 [Specify location of ssh.pid]) 4644 [Specify location of ssh.pid])
4646AC_SUBST([piddir]) 4645AC_SUBST([piddir])
4647 4646
@@ -4799,7 +4798,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
4799 ]], [[ char *utmp = UTMP_FILE; ]])], 4798 ]], [[ char *utmp = UTMP_FILE; ]])],
4800 [ AC_MSG_RESULT([yes]) ], 4799 [ AC_MSG_RESULT([yes]) ],
4801 [ AC_MSG_RESULT([no]) 4800 [ AC_MSG_RESULT([no])
4802 system_utmp_path=no 4801 system_utmp_path=no
4803]) 4802])
4804if test -z "$conf_utmp_location"; then 4803if test -z "$conf_utmp_location"; then
4805 if test x"$system_utmp_path" = x"no" ; then 4804 if test x"$system_utmp_path" = x"no" ; then
@@ -4829,7 +4828,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
4829 ]], [[ char *wtmp = WTMP_FILE; ]])], 4828 ]], [[ char *wtmp = WTMP_FILE; ]])],
4830 [ AC_MSG_RESULT([yes]) ], 4829 [ AC_MSG_RESULT([yes]) ],
4831 [ AC_MSG_RESULT([no]) 4830 [ AC_MSG_RESULT([no])
4832 system_wtmp_path=no 4831 system_wtmp_path=no
4833]) 4832])
4834if test -z "$conf_wtmp_location"; then 4833if test -z "$conf_wtmp_location"; then
4835 if test x"$system_wtmp_path" = x"no" ; then 4834 if test x"$system_wtmp_path" = x"no" ; then
@@ -4862,7 +4861,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
4862 ]], [[ char *wtmpx = WTMPX_FILE; ]])], 4861 ]], [[ char *wtmpx = WTMPX_FILE; ]])],
4863 [ AC_MSG_RESULT([yes]) ], 4862 [ AC_MSG_RESULT([yes]) ],
4864 [ AC_MSG_RESULT([no]) 4863 [ AC_MSG_RESULT([no])
4865 system_wtmpx_path=no 4864 system_wtmpx_path=no
4866]) 4865])
4867if test -z "$conf_wtmpx_location"; then 4866if test -z "$conf_wtmpx_location"; then
4868 if test x"$system_wtmpx_path" = x"no" ; then 4867 if test x"$system_wtmpx_path" = x"no" ; then