summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2003-12-17 18:53:26 +1100
committerDarren Tucker <dtucker@zip.com.au>2003-12-17 18:53:26 +1100
commite937be36c309fff54978e56159503bcfee76d4c0 (patch)
tree71b5bc2c7cfc424e7a68a67f27953600174dfe3f /configure.ac
parent8975ddf11b17bf58191c653a0173d91e50e942c7 (diff)
- (dtucker) [acconfig.h configure.ac uidswap.c] Bug #645: Check for
setres[ug]id() present but not implemented (eg some Linux/glibc combinations).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 25 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e7249b9c9..50b43ae31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.176 2003/12/08 20:35:59 tim Exp $ 1# $Id: configure.ac,v 1.177 2003/12/17 07:53:26 dtucker Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -780,6 +780,30 @@ AC_CHECK_DECL(tcsendbreak,
780 [#include <termios.h>] 780 [#include <termios.h>]
781) 781)
782 782
783dnl Some platorms have setresuid that isn't implemented
784AC_MSG_CHECKING(if setresuid seems to work)
785AC_TRY_RUN([
786#include <stdlib.h>
787#include <errno.h>
788int main(){errno=0; setresuid(0,0,0); if (errno==ENOSYS) exit(1); else exit(0);}
789 ],
790 [AC_MSG_RESULT(yes)],
791 [AC_DEFINE(BROKEN_SETRESUID),
792 AC_MSG_RESULT(not implemented)]
793)
794
795dnl Some platorms have setresgid that isn't implemented
796AC_MSG_CHECKING(if setresgid seems to work)
797AC_TRY_RUN([
798#include <stdlib.h>
799#include <errno.h>
800int main(){errno=0; setresgid(0,0,0); if (errno==ENOSYS) exit(1); else exit(0);}
801 ],
802 [AC_MSG_RESULT(yes)],
803 [AC_DEFINE(BROKEN_SETRESGID)
804 AC_MSG_RESULT(not implemented)]
805)
806
783dnl Checks for time functions 807dnl Checks for time functions
784AC_CHECK_FUNCS(gettimeofday time) 808AC_CHECK_FUNCS(gettimeofday time)
785dnl Checks for utmp functions 809dnl Checks for utmp functions