summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2002-04-23 22:48:46 +1000
committerDamien Miller <djm@mindrot.org>2002-04-23 22:48:46 +1000
commitf6195f2be82cae07660db8f7c3039567f37ffa74 (patch)
tree5acf61fca1ea4bc07f5aa180feb78a0724305116 /configure.ac
parent654a4ef9699c7e396626abd23d725e8534f953c1 (diff)
- (djm) Applied OpenSC smartcard updates from Markus &
Antti Tapaninen <aet@cc.hut.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 17 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index 9c4d7f670..d6824c318 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.47 2002/04/23 10:23:00 djm Exp $ 1# $Id: configure.ac,v 1.48 2002/04/23 12:48:46 djm Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -1719,33 +1719,22 @@ AC_ARG_WITH(sectok,
1719 1719
1720# Check whether user wants OpenSC support 1720# Check whether user wants OpenSC support
1721AC_ARG_WITH(opensc, 1721AC_ARG_WITH(opensc,
1722 [ --with-opensc Enable smartcard support using OpenSC], 1722 AC_HELP_STRING([--with-opensc=PFX],
1723 [ 1723 [Enable smartcard support using OpenSC]),
1724 if test "x$withval" != "xno" ; then 1724 opensc_config_prefix="$withval", opensc_config_prefix="")
1725 if test "x$withval" != "xyes" ; then 1725if test x$opensc_config_prefix != x ; then
1726 CPPFLAGS="$CPPFLAGS -I${withval}" 1726 OPENSC_CONFIG=$opensc_config_prefix/bin/opensc-config
1727 LDFLAGS="$LDFLAGS -L${withval}" 1727 AC_PATH_PROG(OPENSC_CONFIG, opensc-config, no)
1728 if test ! -z "$need_dash_r" ; then 1728 if test "$OPENSC_CONFIG" != "no"; then
1729 LDFLAGS="$LDFLAGS -R${withval}" 1729 LIBOPENSC_CFLAGS=`$OPENSC_CONFIG --cflags`
1730 fi 1730 LIBOPENSC_LIBS=`$OPENSC_CONFIG --libs`
1731 if test ! -z "$blibpath" ; then 1731 CPPFLAGS="$CPPFLAGS $LIBOPENSC_CFLAGS"
1732 blibpath="$blibpath:${withval}" 1732 LDFLAGS="$LDFLAGS $LIBOPENSC_LIBS"
1733 fi 1733 AC_DEFINE(SMARTCARD)
1734 fi 1734 AC_DEFINE(USE_OPENSC)
1735 AC_CHECK_HEADERS(opensc/pkcs15.h) 1735 SCARD_MSG="yes, using OpenSC"
1736 if test "$ac_cv_header_opensc_pkcs15_h" != yes; then 1736 fi
1737 AC_MSG_ERROR(Can't find opensc/pkcs15.h) 1737fi
1738 fi
1739 AC_CHECK_LIB(opensc, sc_pkcs15_bind)
1740 if test "$ac_cv_lib_opensc_sc_pkcs15_bind" != yes; then
1741 AC_MSG_ERROR(Can't find libopensc)
1742 fi
1743 AC_DEFINE(SMARTCARD)
1744 AC_DEFINE(USE_OPENSC)
1745 SCARD_MSG="yes, using OpenSC"
1746 fi
1747 ]
1748)
1749 1738
1750# Check whether user wants Kerberos 5 support 1739# Check whether user wants Kerberos 5 support
1751KRB5_MSG="no" 1740KRB5_MSG="no"