summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2017-05-01 09:55:56 +1000
committerDamien Miller <djm@mindrot.org>2017-05-01 10:05:07 +1000
commitf7849e6c83a4e0f602dea6c834a24091c622d68e (patch)
treea9613115a359687db43ec553591f2fe3e3d9e4f6 /configure.ac
parentf4a6a88ddb6dba6d2f7bfb9e2c9879fcc9633043 (diff)
remove configure --with-ssh1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 0 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index f7a04d551..5cfea38c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,13 +109,10 @@ AC_CHECK_DECL([PR_SET_NO_NEW_PRIVS], [have_linux_no_new_privs=1], , [
109]) 109])
110 110
111openssl=yes 111openssl=yes
112ssh1=no
113COMMENT_OUT_RSA1="#no ssh1#"
114AC_ARG_WITH([openssl], 112AC_ARG_WITH([openssl],
115 [ --without-openssl Disable use of OpenSSL; use only limited internal crypto **EXPERIMENTAL** ], 113 [ --without-openssl Disable use of OpenSSL; use only limited internal crypto **EXPERIMENTAL** ],
116 [ if test "x$withval" = "xno" ; then 114 [ if test "x$withval" = "xno" ; then
117 openssl=no 115 openssl=no
118 ssh1=no
119 fi 116 fi
120 ] 117 ]
121) 118)
@@ -127,31 +124,6 @@ else
127 AC_MSG_RESULT([no]) 124 AC_MSG_RESULT([no])
128fi 125fi
129 126
130AC_ARG_WITH([ssh1],
131 [ --with-ssh1 Enable support for SSH protocol 1],
132 [
133 if test "x$withval" = "xyes" ; then
134 if test "x$openssl" = "xno" ; then
135 AC_MSG_ERROR([Cannot enable SSH protocol 1 with OpenSSL disabled])
136 fi
137 ssh1=yes
138 COMMENT_OUT_RSA1=""
139 elif test "x$withval" = "xno" ; then
140 ssh1=no
141 else
142 AC_MSG_ERROR([unknown --with-ssh1 argument])
143 fi
144 ]
145)
146AC_MSG_CHECKING([whether SSH protocol 1 support is enabled])
147if test "x$ssh1" = "xyes" ; then
148 AC_MSG_RESULT([yes])
149 AC_DEFINE_UNQUOTED([WITH_SSH1], [1], [include SSH protocol version 1 support])
150 AC_SUBST([COMMENT_OUT_RSA1])
151else
152 AC_MSG_RESULT([no])
153fi
154
155use_stack_protector=1 127use_stack_protector=1
156use_toolchain_hardening=1 128use_toolchain_hardening=1
157AC_ARG_WITH([stackprotect], 129AC_ARG_WITH([stackprotect],