summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2002-04-13 11:04:40 +1000
committerDamien Miller <djm@mindrot.org>2002-04-13 11:04:40 +1000
commitfd4c9eee25e4e796b714477c3fbb0286ebe50fb7 (patch)
tree2b9995e4425eac437a6f1b195abf9f096cda0edb /configure.ac
parent927dfd2d7eb8801e444a3bcff7fdf7a628a779f0 (diff)
- (djm) Add KrbV support patch from Simon Wilkinson <simon@sxw.org.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 42 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c0cce4bdd..9516bf7fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.43 2002/04/12 17:26:23 tim Exp $ 1# $Id: configure.ac,v 1.44 2002/04/13 01:04:41 djm Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -1747,7 +1747,45 @@ AC_ARG_WITH(opensc,
1747 ] 1747 ]
1748) 1748)
1749 1749
1750# Check whether user wants Kerberos support 1750# Check whether user wants Kerberos 5 support
1751KRB5_MSG="no"
1752AC_ARG_WITH(kerberos5,
1753 [ --with-kerberos5=PATH Enable Kerberos 5 support],
1754 [
1755 if test "x$withval" != "xno" ; then
1756 if test "x$withval" = "xyes" ; then
1757 KRB5ROOT="/usr/local"
1758 else
1759 KRB5ROOT=${withval}
1760 fi
1761 CPPFLAGS="$CPPFLAGS -I${KRB5ROOT}/include"
1762 LDFLAGS="$LDFLAGS -L${KRB5ROOT}/lib"
1763 AC_DEFINE(KRB5)
1764 KRB5_MSG="yes"
1765 AC_MSG_CHECKING(whether we are using Heimdal)
1766 AC_TRY_COMPILE([ #include <krb5.h> ],
1767 [ char *tmp = heimdal_version; ],
1768 [ AC_MSG_RESULT(yes)
1769 AC_DEFINE(HEIMDAL)
1770 K5LIBS="-lkrb5 -ldes -lcom_err -lasn1 -lroken"
1771 ],
1772 [ AC_MSG_RESULT(no)
1773 K5LIBS="-lkrb5 -lk5crypto -lcom_err"
1774 ]
1775 )
1776 if test ! -z "$need_dash_r" ; then
1777 LDFLAGS="$LDFLAGS -R${KRB5ROOT}/lib"
1778 fi
1779 if test ! -z "$blibpath" ; then
1780 blibpath="$blibpath:${KRB5ROOT}/lib"
1781 fi
1782 AC_CHECK_LIB(resolv, dn_expand, , )
1783
1784 KRB5=yes
1785 fi
1786 ]
1787)
1788# Check whether user wants Kerberos 4 support
1751KRB4_MSG="no" 1789KRB4_MSG="no"
1752AC_ARG_WITH(kerberos4, 1790AC_ARG_WITH(kerberos4,
1753 [ --with-kerberos4=PATH Enable Kerberos 4 support], 1791 [ --with-kerberos4=PATH Enable Kerberos 4 support],
@@ -1827,7 +1865,7 @@ AC_ARG_WITH(afs,
1827 fi 1865 fi
1828 ] 1866 ]
1829) 1867)
1830LIBS="$LIBS $KLIBS" 1868LIBS="$LIBS $KLIBS $K5LIBS"
1831 1869
1832# Looking for programs, paths and files 1870# Looking for programs, paths and files
1833AC_ARG_WITH(rsh, 1871AC_ARG_WITH(rsh,
@@ -2399,6 +2437,7 @@ echo " sshd default user PATH: $H"
2399echo " Manpage format: $MANTYPE" 2437echo " Manpage format: $MANTYPE"
2400echo " PAM support: ${PAM_MSG}" 2438echo " PAM support: ${PAM_MSG}"
2401echo " KerberosIV support: $KRB4_MSG" 2439echo " KerberosIV support: $KRB4_MSG"
2440echo " KerberosV support: $KRB5_MSG"
2402echo " Smartcard support: $SCARD_MSG" 2441echo " Smartcard support: $SCARD_MSG"
2403echo " AFS support: $AFS_MSG" 2442echo " AFS support: $AFS_MSG"
2404echo " S/KEY support: $SKEY_MSG" 2443echo " S/KEY support: $SKEY_MSG"