diff options
author | Damien Miller <djm@mindrot.org> | 1999-11-08 15:30:59 +1100 |
---|---|---|
committer | Damien Miller <djm@mindrot.org> | 1999-11-08 15:30:59 +1100 |
commit | 356a0b004aad93ec570b134664522a3a925ba556 (patch) | |
tree | 3c7cddb50f71a838947d5fda204b569d879dc757 /configure.in | |
parent | 0aa8e5395ca08c7fa927bccd8a763edc4ae61f7b (diff) |
Lots of changes:
- Removed lots of unnecessary checks from autoconf
- Added support and autoconf test for openpty() function (Unix98 pty support)
- Fix for scp not finding ssh if not installed as /usr/bin/ssh
- Added TODO file
- Merged parts of Debian patch From Phil Hands <phil@hands.com>:
- Added ssh-askpass program
- Added ssh-askpass support to ssh-add.c
- Create symlinks for slogin on install
- Fix "distclean" target in makefile
- Added example for ssh-agent to manpage
- Added support for PAM_TEXT_INFO messages
- Disable internal /etc/nologin support if PAM enabled
- Merged latest OpenBSD CVS changes:
- [sshd.c] don't send fail-msg but disconnect if too many authentication
failures
- [sshd.c] replace assert() with error, fatal or packet_disconnect
- [sshd.c] remove unused argument. ok dugsong
- [sshd.c] typo
- [rsa.c] clear buffers used for encryption. ok: niels
- [rsa.c] replace assert() with error, fatal or packet_disconnect
- Fixed coredump after merge of OpenBSD rsa.c patch
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 17 |
1 files changed, 4 insertions, 13 deletions
diff --git a/configure.in b/configure.in index b6038523b..8df3ffc76 100644 --- a/configure.in +++ b/configure.in | |||
@@ -16,12 +16,10 @@ dnl Replace `main' with a function in -lz: | |||
16 | AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first ***])) | 16 | AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first ***])) |
17 | dnl check for nsl | 17 | dnl check for nsl |
18 | AC_CHECK_LIB(nsl, yp_match, , ) | 18 | AC_CHECK_LIB(nsl, yp_match, , ) |
19 | dnl check for pwdb | ||
20 | AC_CHECK_LIB(pwdb, pwdb_new, , ) | ||
21 | dnl check for dl | 19 | dnl check for dl |
22 | AC_CHECK_LIB(dl, dlopen, ,AC_MSG_ERROR([*** libdl missing - please install first ***])) | 20 | AC_CHECK_LIB(dl, dlopen, , ) |
23 | dnl check for pam | 21 | dnl check for pam |
24 | AC_CHECK_LIB(pam, pam_authenticate, ,AC_MSG_ERROR([*** PAM missing - please install first ***])) | 22 | AC_CHECK_LIB(pam, pam_authenticate, , ) |
25 | 23 | ||
26 | dnl Check for stuff in path. | 24 | dnl Check for stuff in path. |
27 | AC_CHECK_PROG(AR, ar, ar) | 25 | AC_CHECK_PROG(AR, ar, ar) |
@@ -31,10 +29,7 @@ dnl Check for ssl headers | |||
31 | AC_CHECK_HEADER(openssl/bn.h, [AC_DEFINE(HAVE_OPENSSL)], [AC_CHECK_HEADER(ssl/bn.h, [AC_DEFINE(HAVE_SSL)], [AC_MSG_ERROR([*** ssl library missing - please install first ***])])]) | 29 | AC_CHECK_HEADER(openssl/bn.h, [AC_DEFINE(HAVE_OPENSSL)], [AC_CHECK_HEADER(ssl/bn.h, [AC_DEFINE(HAVE_SSL)], [AC_MSG_ERROR([*** ssl library missing - please install first ***])])]) |
32 | 30 | ||
33 | dnl Checks for header files. | 31 | dnl Checks for header files. |
34 | AC_HEADER_DIRENT | 32 | AC_CHECK_HEADERS(pty.h) |
35 | AC_HEADER_STDC | ||
36 | AC_HEADER_SYS_WAIT | ||
37 | AC_CHECK_HEADERS(fcntl.h paths.h sys/ioctl.h sys/time.h syslog.h unistd.h) | ||
38 | 33 | ||
39 | dnl Checks for typedefs, structures, and compiler characteristics. | 34 | dnl Checks for typedefs, structures, and compiler characteristics. |
40 | AC_C_CONST | 35 | AC_C_CONST |
@@ -48,10 +43,6 @@ AC_HEADER_TIME | |||
48 | 43 | ||
49 | dnl Checks for library functions. | 44 | dnl Checks for library functions. |
50 | AC_PROG_GCC_TRADITIONAL | 45 | AC_PROG_GCC_TRADITIONAL |
51 | AC_FUNC_MEMCMP | 46 | AC_CHECK_FUNCS(openpty strlcpy mkdtemp arc4random setproctitle) |
52 | AC_TYPE_SIGNAL | ||
53 | AC_FUNC_UTIME_NULL | ||
54 | AC_FUNC_VPRINTF | ||
55 | AC_CHECK_FUNCS(gethostname gettimeofday mkdir rmdir select socket strerror strspn strtol strlcpy mkdtemp arc4random setproctitle) | ||
56 | 47 | ||
57 | AC_OUTPUT(Makefile) | 48 | AC_OUTPUT(Makefile) |