diff options
author | Damien Miller <djm@mindrot.org> | 2000-03-17 23:26:46 +1100 |
---|---|---|
committer | Damien Miller <djm@mindrot.org> | 2000-03-17 23:26:46 +1100 |
commit | d6121d2972c1a6924f6d186ea04eefe9dab774ef (patch) | |
tree | 8a19254a937ac42619ac9900986d795c47458fa6 /configure.in | |
parent | 29ea30d95627517e45e886820e3ef32168bd8dd7 (diff) |
- Checks for 64 bit int types. Problem report from Mats Fredholm
<matsf@init.se>
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 33 |
1 files changed, 17 insertions, 16 deletions
diff --git a/configure.in b/configure.in index 0eeda65ef..a7b90e1f9 100644 --- a/configure.in +++ b/configure.in | |||
@@ -264,7 +264,7 @@ AC_CHECK_SIZEOF(long long int, 8) | |||
264 | AC_MSG_CHECKING([for intXX_t types]) | 264 | AC_MSG_CHECKING([for intXX_t types]) |
265 | AC_TRY_COMPILE( | 265 | AC_TRY_COMPILE( |
266 | [#include <sys/types.h>], | 266 | [#include <sys/types.h>], |
267 | [int16_t a; int32_t b; a = 1235; b = 1235;], | 267 | [int8_t a; int16_t b; int32_t c; int64_t d; a = b = c = d = 1;], |
268 | [ | 268 | [ |
269 | AC_DEFINE(HAVE_INTXX_T) | 269 | AC_DEFINE(HAVE_INTXX_T) |
270 | AC_MSG_RESULT(yes) | 270 | AC_MSG_RESULT(yes) |
@@ -276,7 +276,7 @@ AC_TRY_COMPILE( | |||
276 | AC_MSG_CHECKING([for u_intXX_t types]) | 276 | AC_MSG_CHECKING([for u_intXX_t types]) |
277 | AC_TRY_COMPILE( | 277 | AC_TRY_COMPILE( |
278 | [#include <sys/types.h>], | 278 | [#include <sys/types.h>], |
279 | [u_int16_t c; u_int32_t d; c = 1235; d = 1235;], | 279 | [u_int8_t a; u_int16_t b; u_int32_t c; u_int64_t d; a = b = c = d = 1;], |
280 | [ | 280 | [ |
281 | AC_DEFINE(HAVE_U_INTXX_T) | 281 | AC_DEFINE(HAVE_U_INTXX_T) |
282 | AC_MSG_RESULT(yes) | 282 | AC_MSG_RESULT(yes) |
@@ -292,10 +292,9 @@ then | |||
292 | AC_TRY_COMPILE( | 292 | AC_TRY_COMPILE( |
293 | [#include <sys/bitypes.h>], | 293 | [#include <sys/bitypes.h>], |
294 | [ | 294 | [ |
295 | u_int16_t c; u_int32_t d; | 295 | int8_t a; int16_t b; int32_t c; int64_t d; |
296 | int16_t e; int32_t f; | 296 | u_int8_t e; u_int16_t f; u_int32_t g; u_int64_t h; |
297 | c = 1235; d = 1235; | 297 | a = b = c = d = e = f = g = h = 1; |
298 | e = 1235; f = 1235; | ||
299 | ], | 298 | ], |
300 | [ | 299 | [ |
301 | AC_DEFINE(HAVE_U_INTXX_T) | 300 | AC_DEFINE(HAVE_U_INTXX_T) |
@@ -306,16 +305,18 @@ then | |||
306 | ) | 305 | ) |
307 | fi | 306 | fi |
308 | 307 | ||
309 | AC_MSG_CHECKING([for uintXX_t types]) | 308 | if test -z "$have_u_intxx_t" ; then |
310 | AC_TRY_COMPILE( | 309 | AC_MSG_CHECKING([for uintXX_t types]) |
311 | [#include <sys/types.h>], | 310 | AC_TRY_COMPILE( |
312 | [uint16_t c; uint32_t d; c = 1235; d = 1235;], | 311 | [#include <sys/types.h>], |
313 | [ | 312 | [uint8_t a; uint16_t b; uint32_t c; uint64_t d; a = b = c = d = 1;], |
314 | AC_DEFINE(HAVE_UINTXX_T) | 313 | [ |
315 | AC_MSG_RESULT(yes) | 314 | AC_DEFINE(HAVE_UINTXX_T) |
316 | ], | 315 | AC_MSG_RESULT(yes) |
317 | [AC_MSG_RESULT(no)] | 316 | ], |
318 | ) | 317 | [AC_MSG_RESULT(no)] |
318 | ) | ||
319 | fi | ||
319 | 320 | ||
320 | AC_MSG_CHECKING([for socklen_t]) | 321 | AC_MSG_CHECKING([for socklen_t]) |
321 | AC_TRY_COMPILE( | 322 | AC_TRY_COMPILE( |