summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2001-03-14 11:39:45 +1100
committerDamien Miller <djm@mindrot.org>2001-03-14 11:39:45 +1100
commit3c02768950ba1f17dc90d9f4a9538a8eec711c4f (patch)
treefe2b9f417d7923cdb570ea6a67cfdc8a65877661 /configure.in
parent46e55aaabc33549b91a85052aa048dffaf061761 (diff)
- (djm) Add replacement glob() from OpenBSD libc if the system glob is
missing or lacks the GLOB_ALTDIRFUNC extension - (djm) Remove -I$(srcdir)/openbsd-compat from CFLAGS, refer to headers relatively. Avoids conflict between glob.h and /usr/include/glob.h
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 21 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index d31bf1a72..d3a902a86 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
1# $Id: configure.in,v 1.264 2001/03/12 01:32:12 tim Exp $ 1# $Id: configure.in,v 1.265 2001/03/14 00:39:46 djm Exp $
2 2
3AC_INIT(ssh.c) 3AC_INIT(ssh.c)
4 4
@@ -368,7 +368,25 @@ AC_CHECK_FUNC(utimes,
368AC_FUNC_STRFTIME 368AC_FUNC_STRFTIME
369 369
370# Checks for header files. 370# Checks for header files.
371AC_CHECK_HEADERS(bstring.h endian.h floatingpoint.h getopt.h lastlog.h limits.h login.h login_cap.h maillock.h netdb.h netgroup.h netinet/in_systm.h paths.h poll.h pty.h regex.h shadow.h security/pam_appl.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/queue.h sys/select.h sys/stat.h sys/stropts.h sys/sysmacros.h sys/time.h sys/ttcompat.h sys/un.h stddef.h time.h ttyent.h usersec.h util.h utime.h utmp.h utmpx.h vis.h) 371AC_CHECK_HEADERS(bstring.h endian.h floatingpoint.h getopt.h glob.h lastlog.h limits.h login.h login_cap.h maillock.h netdb.h netgroup.h netinet/in_systm.h paths.h poll.h pty.h regex.h shadow.h security/pam_appl.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h sys/poll.h sys/queue.h sys/select.h sys/stat.h sys/stropts.h sys/sysmacros.h sys/time.h sys/ttcompat.h sys/un.h stddef.h time.h ttyent.h usersec.h util.h utime.h utmp.h utmpx.h vis.h)
372
373# Check for ALTDIRFUNC glob() extension
374AC_MSG_CHECKING(for GLOB_ALTDIRFUNC support)
375AC_EGREP_CPP(FOUNDIT,
376 [
377 #include <glob.h>
378 #ifdef GLOB_ALTDIRFUNC
379 FOUNDIT
380 #endif
381 ],
382 [
383 AC_DEFINE(GLOB_HAS_ALTDIRFUNC)
384 AC_MSG_RESULT(yes)
385 ],
386 [
387 AC_MSG_RESULT(no)
388 ]
389)
372 390
373# Check whether user wants Kerberos support 391# Check whether user wants Kerberos support
374KRB4_MSG="no" 392KRB4_MSG="no"
@@ -491,7 +509,7 @@ AC_ARG_WITH(tcp-wrappers,
491) 509)
492 510
493dnl Checks for library functions. 511dnl Checks for library functions.
494AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_sa clock fchown fchmod freeaddrinfo futimes gai_strerror getcwd getaddrinfo getgrouplist getnameinfo getrlimit getrusage getttyent inet_aton inet_ntoa innetgr login_getcapbool md5_crypt memmove mkdtemp on_exit openpty realpath rresvport_af setdtablesize setenv seteuid setlogin setproctitle setreuid setrlimit setsid sigaction sigvec snprintf strerror strlcat strlcpy strmode strsep strtok_r sysconf tcgetpgrp utimes vsnprintf vhangup vis waitpid _getpty __b64_ntop) 512AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_sa clock fchown fchmod freeaddrinfo futimes gai_strerror getcwd getaddrinfo getgrouplist getnameinfo getrlimit getrusage getttyent glob inet_aton inet_ntoa innetgr login_getcapbool md5_crypt memmove mkdtemp on_exit openpty realpath rresvport_af setdtablesize setenv seteuid setlogin setproctitle setreuid setrlimit setsid sigaction sigvec snprintf strerror strlcat strlcpy strmode strsep strtok_r sysconf tcgetpgrp utimes vsnprintf vhangup vis waitpid _getpty __b64_ntop)
495dnl Checks for time functions 513dnl Checks for time functions
496AC_CHECK_FUNCS(gettimeofday time) 514AC_CHECK_FUNCS(gettimeofday time)
497dnl Checks for libutil functions 515dnl Checks for libutil functions