summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-11-15 17:10:57 +1100
committerDamien Miller <djm@mindrot.org>1999-11-15 17:10:57 +1100
commit3f905872b0d15be24078c4db131f0ecdb5ebb5e6 (patch)
tree700210571ddc52d55dcbaabf593e52b5d7531c3f /configure.in
parentc6d5ce86a9ed296dbc99b8fc593099a87830fd18 (diff)
- Merged more Solaris compability from Marc G. Fournier
<marc.fournier@acadiau.ca> - Wrote autoconf tests for __progname symbol
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 30 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index fd6aea36b..9fe1a92ff 100644
--- a/configure.in
+++ b/configure.in
@@ -55,14 +55,7 @@ AC_CHECK_LIB(dl, dlopen, , )
55AC_CHECK_LIB(pam, pam_authenticate, , ) 55AC_CHECK_LIB(pam, pam_authenticate, , )
56 56
57dnl Checks for header files. 57dnl Checks for header files.
58AC_CHECK_HEADERS(pty.h endian.h paths.h lastlog.h shadow.h netgroup.h) 58AC_CHECK_HEADERS(pty.h endian.h paths.h lastlog.h shadow.h netgroup.h maillock.h)
59
60dnl Check for ut_host field in utmp
61AC_MSG_CHECKING([whether utmp.h has ut_host field])
62AC_EGREP_HEADER(ut_host, utmp.h,
63 [AC_DEFINE(HAVE_HOST_IN_UTMP) AC_MSG_RESULT(yes); ],
64 [AC_MSG_RESULT(no)]
65)
66 59
67dnl Checks for library functions. 60dnl Checks for library functions.
68AC_CHECK_FUNCS(openpty strlcpy mkdtemp arc4random setproctitle setlogin) 61AC_CHECK_FUNCS(openpty strlcpy mkdtemp arc4random setproctitle setlogin)
@@ -144,4 +137,33 @@ if test -z "$RANDOM_POOL" -a -z "$EGD_POOL"; then
144 AC_MSG_ERROR([No random device found, and no EGD random pool specified]) 137 AC_MSG_ERROR([No random device found, and no EGD random pool specified])
145fi 138fi
146 139
140dnl Check for ut_host field in utmp
141AC_MSG_CHECKING([whether utmp.h has ut_host field])
142AC_EGREP_HEADER(ut_host, utmp.h,
143 [AC_DEFINE(HAVE_HOST_IN_UTMP) AC_MSG_RESULT(yes); ],
144 [AC_MSG_RESULT(no)]
145)
146
147dnl Look for lastlog location
148AC_MSG_CHECKING([location of lastlog file])
149for lastlog in /var/log/lastlog /var/adm/lastlog /etc/security/lastlog ; do
150 if test -f $lastlog ; then
151 AC_MSG_RESULT($lastlog)
152 AC_DEFINE_UNQUOTED(LASTLOG_LOCATION, "$lastlog")
153 break
154 fi
155done
156
157AC_MSG_CHECKING([whether libc defines __progname])
158AC_TRY_LINK([],
159 [extern char *__progname;],
160 [
161 AC_DEFINE(HAVE___PROGNAME)
162 AC_MSG_RESULT(yes)
163 ],
164 [
165 AC_MSG_RESULT(no)
166 ]
167)
168
147AC_OUTPUT(Makefile) 169AC_OUTPUT(Makefile)