summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-10-28 13:25:17 +1000
committerDamien Miller <djm@mindrot.org>1999-10-28 13:25:17 +1000
commit7f6ea0264d01aa40b20df8dc75141631479da054 (patch)
treea30aa324db2b41c64e1216ce73b7b7468e5ff706 /configure.in
parent3d112efc672b877c74893229d3fd30f99489b9ff (diff)
- Integrated patch from Dan Brosemer <odin@linuxfreak.com>
- Build fixes - Autoconf - Change binary names to open* - Fixed autoconf script to detect PAM on RH6.1 - Added tests for libpwdb, and OpenBSD functions to autoconf (not used yet)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in54
1 files changed, 54 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 000000000..0fac461c8
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,54 @@
1dnl Process this file with autoconf to produce a configure script.
2AC_INIT(auth-krb4.c)
3
4AC_CONFIG_HEADER(config.h)
5
6dnl Checks for programs.
7AC_PROG_CC
8AC_PROG_RANLIB
9
10dnl Checks for libraries.
11dnl Replace `main' with a function in -lcrypto:
12AC_CHECK_LIB(crypto, CRYPTO_lock, ,AC_MSG_ERROR([*** libcrypto missing - please install first ***]))
13dnl Replace `main' with a function in -lutil:
14AC_CHECK_LIB(util, logout, ,AC_MSG_ERROR([*** -lutil missing - this is part of libc. ***]))
15dnl Replace `main' with a function in -lz:
16AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first ***]))
17dnl check for pwdb
18AC_CHECK_LIB(pwdb, pwdb_new, ,AC_MSG_ERROR([*** libpwdb missing - please install first ***]))
19dnl check for dl
20AC_CHECK_LIB(dl, dlopen, ,AC_MSG_ERROR([*** libdl missing - please install first ***]))
21dnl check for pam
22AC_CHECK_LIB(pam, pam_authenticate, ,AC_MSG_ERROR([*** PAM missing - please install first ***]))
23
24dnl Check for stuff in path.
25AC_CHECK_PROG(AR, ar, ar)
26
27dnl Check for ssl headers
28AC_CHECK_HEADER(openssl/bn.h, [AC_DEFINE(HAVE_OPENSSL)], [AC_CHECK_HEADER(ssl/bn.h, [AC_DEFINE(HAVE_SSL)], [AC_MSG_ERROR([*** ssl library missing - please install first ***])])])
29
30dnl Checks for header files.
31AC_HEADER_DIRENT
32AC_HEADER_STDC
33AC_HEADER_SYS_WAIT
34AC_CHECK_HEADERS(fcntl.h paths.h sys/ioctl.h sys/time.h syslog.h unistd.h)
35
36dnl Checks for typedefs, structures, and compiler characteristics.
37AC_C_CONST
38AC_TYPE_UID_T
39AC_C_INLINE
40AC_TYPE_MODE_T
41AC_TYPE_OFF_T
42AC_TYPE_SIZE_T
43AC_STRUCT_ST_BLKSIZE
44AC_HEADER_TIME
45
46dnl Checks for library functions.
47AC_PROG_GCC_TRADITIONAL
48AC_FUNC_MEMCMP
49AC_TYPE_SIGNAL
50AC_FUNC_UTIME_NULL
51AC_FUNC_VPRINTF
52AC_CHECK_FUNCS(gethostname gettimeofday mkdir rmdir select socket strerror strspn strtol strlcpy mkdtemp arc4random setproctitle)
53
54AC_OUTPUT(Makefile)