summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-11-19 13:03:25 +1100
committerDamien Miller <djm@mindrot.org>1999-11-19 13:03:25 +1100
commit8029775b77e8f8bc380518f9f734a9d979025bbb (patch)
tree3905893864df5ce304b30164378fcad91c10bcb0 /configure.in
parent18ac1719687a6671242d6a001cab01d55036ef8b (diff)
- Added autoconf option to enable Kerberos 4 support (untested)
- Added autoconf option to enable AFS support (untested) - Added autoconf option to enable S/Key support (untested) - Added autoconf option to enable TCP wrappers support (compiles OK)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 05a354d1a..0b54fd58a 100644
--- a/configure.in
+++ b/configure.in
@@ -166,4 +166,41 @@ AC_TRY_LINK([],
166 ] 166 ]
167) 167)
168 168
169dnl Check whether user wants Kerberos support
170AC_ARG_WITH(kerberos4,
171 [ --with-kerberos4 Enable Kerberos 4 support],
172 [
173 AC_DEFINE(KRB4)
174 LIBS="$LIBS -lkrb"
175 CFLAGS="$CFLAGS -I/usr/include/kerberosIV"
176 ]
177)
178
179dnl Check whether user wants AFS support
180AC_ARG_WITH(kerberos4,
181 [ --with-afs Enable AFS support],
182 [
183 AC_DEFINE(AFS)
184 LIBS="$LIBS -lkafs"
185 ]
186)
187
188dnl Check whether user wants S/Key support
189AC_ARG_WITH(skey,
190 [ --with-skey Enable S/Key support],
191 [
192 AC_DEFINE(SKEY)
193 LIBS="$LIBS -lskey"
194 ]
195)
196
197dnl Check whether user wants TCP wrappers support
198AC_ARG_WITH(skey,
199 [ --with-tcp-wrappers Enable tcpwrappers support],
200 [
201 AC_DEFINE(LIBWRAP)
202 LIBS="$LIBS -lwrap"
203 ]
204)
205
169AC_OUTPUT(Makefile) 206AC_OUTPUT(Makefile)