summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-12-29 10:36:45 +1100
committerDamien Miller <djm@mindrot.org>1999-12-29 10:36:45 +1100
commit9505851f31c52cbb76866225679fdceb788dcc5e (patch)
tree9c27bccffcf4da90c32ea6f672821786b31ea9c5 /configure.in
parentac3a4b4a96d952a467e1cdf660f9d471e1141f6f (diff)
- Detect missing size_t and typedef it.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 581380ae2..3b1f125c6 100644
--- a/configure.in
+++ b/configure.in
@@ -192,6 +192,18 @@ AC_TRY_COMPILE(
192 [AC_MSG_RESULT(no)] 192 [AC_MSG_RESULT(no)]
193) 193)
194 194
195AC_MSG_CHECKING([For size_t])
196AC_TRY_COMPILE(
197 [#include <sys/types.h>],
198 [#include <sys/socket.h>],
199 [size_t foo; foo = 1235;],
200 [
201 AC_DEFINE(HAVE_SIZE_T)
202 AC_MSG_RESULT(yes)
203 ],
204 [AC_MSG_RESULT(no)]
205)
206
195AC_ARG_WITH(pam, 207AC_ARG_WITH(pam,
196 [ --without-pam Disable PAM support ], 208 [ --without-pam Disable PAM support ],
197 [ 209 [