summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-02-03 13:58:51 +1100
committerDamien Miller <djm@mindrot.org>2000-02-03 13:58:51 +1100
commit0c0e4bfe3c126e2a172db7b978f7e6360c6580d5 (patch)
treee0cf87b0fe5cd08c8a111f7aa54c7b0da582896c /configure.in
parent1852246d30592c4b511db0755a806f90a4842852 (diff)
- Add --with-ssl-dir option
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 2ff4aba59..1176bfc48 100644
--- a/configure.in
+++ b/configure.in
@@ -46,14 +46,21 @@ if test ! -z "$rsh_path" ; then
46 AC_DEFINE_UNQUOTED(RSH_PATH, "$rsh_path") 46 AC_DEFINE_UNQUOTED(RSH_PATH, "$rsh_path")
47fi 47fi
48 48
49dnl Checks for compiler characteristics
50if test "$GCC" = "yes"; then CFLAGS="$CFLAGS -Wall"; fi 49if test "$GCC" = "yes"; then CFLAGS="$CFLAGS -Wall"; fi
51 50
52AC_C_INLINE 51AC_C_INLINE
53 52
54dnl Check for OpenSSL/SSLeay directories. 53AC_ARG_WITH(ssl-dir,
54 [ --with-ssl-dir=PATH Specify path to OpenSSL installation ],
55 [
56 if test "x$withval" != "$xno" ; then
57 ssldir=$withval
58 fi
59 ]
60)
61
55AC_MSG_CHECKING([for OpenSSL/SSLeay directory]) 62AC_MSG_CHECKING([for OpenSSL/SSLeay directory])
56for ssldir in $prefix /usr /usr/local/openssl /usr/lib/openssl /usr/local/ssl /usr/lib/ssl /usr/local $prefix /usr/pkg ; do 63for ssldir in $ssldir $prefix /usr /usr/local/openssl /usr/lib/openssl /usr/local/ssl /usr/lib/ssl /usr/local $prefix /usr/pkg ; do
57 if test -f "$ssldir/include/openssl/crypto.h"; then 64 if test -f "$ssldir/include/openssl/crypto.h"; then
58 AC_DEFINE(HAVE_OPENSSL) 65 AC_DEFINE(HAVE_OPENSSL)
59 GOT_SSL="yes" 66 GOT_SSL="yes"