summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-01-07 08:45:55 +1100
committerDamien Miller <djm@mindrot.org>2000-01-07 08:45:55 +1100
commit105b7f073ac053d8f00d2b79d9fd8555d34a84f3 (patch)
tree581b29d53004f268a493989df85681426dad94b2 /configure.in
parentf20c2aa89cd864f53e9480ea3b7f7747ecf7d8a9 (diff)
- Better KrbIV / AFS detection, based on patch from:
Holger Trapp <Holger.Trapp@Informatik.TU-Chemnitz.DE>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in50
1 files changed, 43 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 7480349a2..127cd055e 100644
--- a/configure.in
+++ b/configure.in
@@ -52,6 +52,7 @@ case "$host" in
52 AC_MSG_RESULT(yes) 52 AC_MSG_RESULT(yes)
53 AC_DEFINE(HAVE_HPUX_TRUSTED_SYSTEM_PW) 53 AC_DEFINE(HAVE_HPUX_TRUSTED_SYSTEM_PW)
54 LIBS="$LIBS -lsec" 54 LIBS="$LIBS -lsec"
55 AC_MSG_WARN([This configuration is untested])
55 else 56 else
56 AC_MSG_RESULT(no) 57 AC_MSG_RESULT(no)
57 AC_DEFINE(DISABLE_SHADOW) 58 AC_DEFINE(DISABLE_SHADOW)
@@ -60,6 +61,9 @@ case "$host" in
60*-*-solaris*) 61*-*-solaris*)
61 AC_DEFINE(USE_UTMPX) 62 AC_DEFINE(USE_UTMPX)
62 ;; 63 ;;
64*-*-aix*)
65 AFS_LIBS="-lld"
66 ;;
63*-*-irix5*) 67*-*-irix5*)
64 no_libsocket=1 68 no_libsocket=1
65 no_libnsl=1 69 no_libnsl=1
@@ -400,23 +404,56 @@ AC_TRY_LINK([],
400 404
401dnl Check whether user wants Kerberos support 405dnl Check whether user wants Kerberos support
402AC_ARG_WITH(kerberos4, 406AC_ARG_WITH(kerberos4,
403 [ --with-kerberos4 Enable Kerberos 4 support], 407 [ --with-kerberos4=PATH Enable Kerberos 4 support],
404 [ 408 [
405 if test "x$withval" != "$xno" ; then 409 if test "x$withval" != "$xno" ; then
410
411 if test "x$withval" != "$xyes" ; then
412 CFLAGS="$CFLAGS -I${withval}/include"
413 LDFLAGS="$LDFLAGS -L${withval}/lib"
414 else
415 if test -d /usr/include/kerberosIV ; then
416 CFLAGS="$CFLAGS -I/usr/include/kerberosIV"
417 fi
418 fi
419
420 AC_CHECK_HEADERS(krb.h)
421 AC_CHECK_LIB(krb, main)
422 if test "$ac_cv_header_krb_h" != yes; then
423 AC_MSG_WARN([Cannot find krb.h, build may fail])
424 fi
425 if test "$ac_cv_lib_krb_main" != yes; then
426 AC_MSG_WARN([Cannot find libkrb, build may fail])
427 fi
428
429 LIBS="$LIBS -lkrb -ldes"
430 AC_CHECK_LIB(resolv, dn_expand, , )
431 KRB4=yes
406 AC_DEFINE(KRB4) 432 AC_DEFINE(KRB4)
407 LIBS="$LIBS -lkrb"
408 CFLAGS="$CFLAGS -I/usr/include/kerberosIV"
409 fi 433 fi
410 ] 434 ]
411) 435)
412 436
413dnl Check whether user wants AFS support 437dnl Check whether user wants AFS support
414AC_ARG_WITH(afs, 438AC_ARG_WITH(afs,
415 [ --with-afs Enable AFS support], 439 [ --with-afs=PATH Enable AFS support],
416 [ 440 [
417 if test "x$withval" != "$xno" ; then 441 if test "x$withval" != "$xno" ; then
418 AC_DEFINE(AFS) 442
443 if test "x$withval" != "$xyes" ; then
444 CFLAGS="$CFLAGS -I${withval}/include"
445 LFLAGS="$LFLAGS -L${withval}/lib"
446 fi
447
448 if test -z "$KRB4" ; then
449 AC_MSG_WARN([AFS requires Kerberos IV support, build may fail])
450 fi
451
419 LIBS="$LIBS -lkafs" 452 LIBS="$LIBS -lkafs"
453 if test ! -z "$AFS_LIBS" ; then
454 LIBS="$LIBS $AFS_LIBS"
455 fi
456 AC_DEFINE(AFS)
420 fi 457 fi
421 ] 458 ]
422) 459)
@@ -438,11 +475,10 @@ AC_ARG_WITH(tcp-wrappers,
438 [ 475 [
439 if test "x$withval" != "$xno" ; then 476 if test "x$withval" != "$xno" ; then
440 AC_DEFINE(LIBWRAP) 477 AC_DEFINE(LIBWRAP)
441 LIBWRAP="-lwrap" 478 LIBS="$LIBS -lwrap"
442 fi 479 fi
443 ] 480 ]
444) 481)
445AC_SUBST(LIBWRAP)
446 482
447dnl Check whether to enable MD5 passwords 483dnl Check whether to enable MD5 passwords
448AC_ARG_WITH(md5-passwords, 484AC_ARG_WITH(md5-passwords,