summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-03-17 10:54:15 +1100
committerDamien Miller <djm@mindrot.org>2000-03-17 10:54:15 +1100
commit29ea30d95627517e45e886820e3ef32168bd8dd7 (patch)
treea18a0eb90f9b74dfb4e3b2eb9e54888893693f1b /configure.in
parent696be9031b42c341c45ec36e2cd10db7869fb93a (diff)
- Clarified --with-default-path option.
- Added -blibpath handling for AIX to work around stupid runtime linking. Problem elucidated by gshapiro@SENDMAIL.ORG by way of Jim Knoble <jmknoble@pobox.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 81265f1e8..0eeda65ef 100644
--- a/configure.in
+++ b/configure.in
@@ -29,6 +29,9 @@ case "$host" in
29 AFS_LIBS="-lld" 29 AFS_LIBS="-lld"
30 CFLAGS="$CFLAGS -I/usr/local/include" 30 CFLAGS="$CFLAGS -I/usr/local/include"
31 LDFLAGS="$LDFLAGS -L/usr/local/lib" 31 LDFLAGS="$LDFLAGS -L/usr/local/lib"
32 if test "$LD" != "gcc" -a -z "$blibpath"; then
33 blibpath="/usr/lib:/lib:/usr/local/lib"
34 fi
32 AC_DEFINE(BROKEN_GETADDRINFO) 35 AC_DEFINE(BROKEN_GETADDRINFO)
33 ;; 36 ;;
34*-*-hpux10*) 37*-*-hpux10*)
@@ -239,6 +242,9 @@ else
239 if test ! -z "$need_dash_r" ; then 242 if test ! -z "$need_dash_r" ; then
240 LDFLAGS="$LDFLAGS -R$ssldir/lib -R$ssldir" 243 LDFLAGS="$LDFLAGS -R$ssldir/lib -R$ssldir"
241 fi 244 fi
245 if test ! -z "$blibpath" ; then
246 blibpath="$blibpath:$ssldir:$ssldir/lib"
247 fi
242fi 248fi
243if test -z "$WANTS_RSAREF" ; then 249if test -z "$WANTS_RSAREF" ; then
244 LIBS="$saved_LIBS -lcrypto" 250 LIBS="$saved_LIBS -lcrypto"
@@ -646,6 +652,12 @@ AC_ARG_WITH(kerberos4,
646 if test "x$withval" != "$xyes" ; then 652 if test "x$withval" != "$xyes" ; then
647 CFLAGS="$CFLAGS -I${withval}/include" 653 CFLAGS="$CFLAGS -I${withval}/include"
648 LDFLAGS="$LDFLAGS -L${withval}/lib" 654 LDFLAGS="$LDFLAGS -L${withval}/lib"
655 if test ! -z "$need_dash_r" ; then
656 LDFLAGS="$LDFLAGS -R${withval}/lib"
657 fi
658 if test ! -z "$blibpath" ; then
659 blibpath="$blibpath:${withval}/lib"
660 fi
649 else 661 else
650 if test -d /usr/include/kerberosIV ; then 662 if test -d /usr/include/kerberosIV ; then
651 CFLAGS="$CFLAGS -I/usr/include/kerberosIV" 663 CFLAGS="$CFLAGS -I/usr/include/kerberosIV"
@@ -826,4 +838,9 @@ AC_ARG_WITH(pid-dir,
826AC_DEFINE_UNQUOTED(PIDDIR, "$piddir") 838AC_DEFINE_UNQUOTED(PIDDIR, "$piddir")
827AC_SUBST(piddir) 839AC_SUBST(piddir)
828 840
841if test ! -z "$blibpath" ; then
842 LDFLAGS="$LDFLAGS -blibpath:$blibpath"
843 AC_MSG_WARN([Please check and edit -blibpath in LDFLAGS in Makefile])
844fi
845
829AC_OUTPUT(Makefile) 846AC_OUTPUT(Makefile)