summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBen Lindstrom <mouring@eviladmin.org>2000-11-10 02:41:30 +0000
committerBen Lindstrom <mouring@eviladmin.org>2000-11-10 02:41:30 +0000
commit305fb0018a1485a040eac264527b3fd4557a461a (patch)
tree731fd59b242eddc0560c712cb8c7652e0301f3d4 /configure.in
parentdbcea870630e6e6cedc6937d33da4e2e4c6d5390 (diff)
20001110
- (bal) Fixed dropped answer from skey_keyinfo() in auth1.c - (bal) Changed from --with-skey to --with-skey=PATH in configure.in - (bal) Added in check to verify S/Key library is being detected in configure.in - (bal) next-posix.h - added another prototype wrapped in POSIX ifdef/endif. Patch by Mark Miller <markm@swoon.net> - (bal) Added 'util.h' header to loginrec.c only if HAVE_UTIL_H is defined to remove warnings under MacOS X. Patch by Mark Miller <markm@swoon.net> - (bal) Fixed LDFLAG mispelling in configure.in for --with-afs
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0c43efcb8..be500da20 100644
--- a/configure.in
+++ b/configure.in
@@ -1085,7 +1085,7 @@ AC_ARG_WITH(afs,
1085 1085
1086 if test "x$withval" != "xyes" ; then 1086 if test "x$withval" != "xyes" ; then
1087 CFLAGS="$CFLAGS -I${withval}/include" 1087 CFLAGS="$CFLAGS -I${withval}/include"
1088 LFLAGS="$LFLAGS -L${withval}/lib" 1088 LDFLAGS="$LDFLAGS -L${withval}/lib"
1089 fi 1089 fi
1090 1090
1091 if test -z "$KRB4" ; then 1091 if test -z "$KRB4" ; then
@@ -1106,12 +1106,24 @@ LIBS="$LIBS $KLIBS"
1106# Check whether user wants S/Key support 1106# Check whether user wants S/Key support
1107SKEY_MSG="no" 1107SKEY_MSG="no"
1108AC_ARG_WITH(skey, 1108AC_ARG_WITH(skey,
1109 [ --with-skey Enable S/Key support], 1109 [ --with-skey=PATH Enable S/Key support],
1110 [ 1110 [
1111 if test "x$withval" != "xno" ; then 1111 if test "x$withval" != "xno" ; then
1112
1113 if test "x$withval" != "xyes" ; then
1114 CFLAGS="$CFLAGS -I${withval}/include"
1115 LDFLAGS="$LDFLAGS -L${withval}/lib"
1116 fi
1117
1112 AC_DEFINE(SKEY) 1118 AC_DEFINE(SKEY)
1113 LIBS="$LIBS -lskey" 1119 LIBS="$LIBS -lskey"
1114 SKEY_MSG="yes" 1120 SKEY_MSG="yes"
1121
1122 AC_CHECK_FUNC(skey_keyinfo,
1123 [],
1124 [
1125 AC_MSG_ERROR([** Incomplete or missing s/key libraries.])
1126 ])
1115 fi 1127 fi
1116 ] 1128 ]
1117) 1129)