summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-04-30 09:30:44 +1000
committerDamien Miller <djm@mindrot.org>2000-04-30 09:30:44 +1000
commit4018c1985d6e34f4625132965e814880ac3075ba (patch)
tree1a3450e78dc2fa600f485a07a5c5a866781f082c /configure.in
parent1bead335d7381b553bc4a13b3ea2b9dc09679123 (diff)
- Integrate Andre Lucas' <andre.lucas@dial.pipex.com> entropy collection
patch. - Adds timeout to entropy collection - Disables slow entropy sources - Load and save seed file - Changed entropy seed code to user per-user seeds only (server seed is saved in root's .ssh directory) - Use atexit() and fatal cleanups to save seed on exit
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fbf117b94..c533d4209 100644
--- a/configure.in
+++ b/configure.in
@@ -43,6 +43,7 @@ case "$host" in
43 LDFLAGS="$LDFLAGS -L/usr/local/lib" 43 LDFLAGS="$LDFLAGS -L/usr/local/lib"
44 AC_DEFINE(IPADDR_IN_DISPLAY) 44 AC_DEFINE(IPADDR_IN_DISPLAY)
45 AC_DEFINE(USE_UTMPX) 45 AC_DEFINE(USE_UTMPX)
46 AC_DEFINE(NEED_IN_SYSTM_H)
46 AC_MSG_CHECKING(for HPUX trusted system password database) 47 AC_MSG_CHECKING(for HPUX trusted system password database)
47 if test -f /tcb/files/auth/system/default; then 48 if test -f /tcb/files/auth/system/default; then
48 AC_MSG_RESULT(yes) 49 AC_MSG_RESULT(yes)
@@ -907,9 +908,24 @@ AC_ARG_WITH(pid-dir,
907 fi 908 fi
908 ] 909 ]
909) 910)
911
910AC_DEFINE_UNQUOTED(PIDDIR, "$piddir") 912AC_DEFINE_UNQUOTED(PIDDIR, "$piddir")
911AC_SUBST(piddir) 913AC_SUBST(piddir)
912 914
915
916# Change default command timeout for builtin PRNG
917entropy_timeout=100
918AC_ARG_WITH(entropy-timeout,
919 [ --with-entropy-timeout Specify entropy gathering command timeout (msec)],
920 [
921 if test "x$withval" != "xno" ; then
922 entropy_timeout=$withval
923 fi
924 ]
925)
926AC_DEFINE_UNQUOTED(ENTROPY_TIMEOUT_MSEC, $entropy_timeout)
927
928
913if test ! -z "$blibpath" ; then 929if test ! -z "$blibpath" ; then
914 LDFLAGS="$LDFLAGS -blibpath:$blibpath" 930 LDFLAGS="$LDFLAGS -blibpath:$blibpath"
915 AC_MSG_WARN([Please check and edit -blibpath in LDFLAGS in Makefile]) 931 AC_MSG_WARN([Please check and edit -blibpath in LDFLAGS in Makefile])