summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-06-05 09:37:43 +1000
committerDamien Miller <djm@mindrot.org>2000-06-05 09:37:43 +1000
commite37bfc19f7263b838896ae403e55aa703a06b69a (patch)
tree561c873c0c523fc40471e5ee29377829070983be /configure.in
parent61e67250dc0d6a3406c4b2cd6cb787663d194481 (diff)
- (djm) Added --with-cflags, --with-ldflags and --with-libs options to
configure.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8056ada05..c242246d3 100644
--- a/configure.in
+++ b/configure.in
@@ -120,6 +120,33 @@ case "$host" in
120 ;; 120 ;;
121esac 121esac
122 122
123# Allow user to specify flags
124AC_ARG_WITH(cflags,
125 [ --with-cflags Specify additional flags to pass to compiler],
126 [
127 if test "x$withval" != "xno" ; then
128 CFLAGS="$CFLAGS $withval"
129 fi
130 ]
131)
132AC_ARG_WITH(ldflags,
133 [ --with-ldlags Specify additional flags to pass to linker],
134 [
135 if test "x$withval" != "xno" ; then
136 LDFLAGS="$LDFLAGS $withval"
137 fi
138 ]
139)
140AC_ARG_WITH(libs,
141 [ --with-libs Specify additional libraries to link with],
142 [
143 if test "x$withval" != "xno" ; then
144 LIBS="$LIBS $withval"
145 fi
146 ]
147)
148
149
123# Checks for libraries. 150# Checks for libraries.
124AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first ***])) 151AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first ***]))
125AC_CHECK_LIB(util, login, AC_DEFINE(HAVE_LIBUTIL_LOGIN) LIBS="$LIBS -lutil") 152AC_CHECK_LIB(util, login, AC_DEFINE(HAVE_LIBUTIL_LOGIN) LIBS="$LIBS -lutil")