summaryrefslogtreecommitdiff
path: root/debian/patches/consolekit.patch
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2013-09-14 23:42:11 +0100
committerColin Watson <cjwatson@debian.org>2013-09-14 23:42:11 +0100
commit327155e6824b3ee13837bdde04e4eb47e147ff46 (patch)
tree8f8743122403c7a2e6ed919156711fb1520c657f /debian/patches/consolekit.patch
parent0334ce32304e9ba2a10ee5ca49ca6e8ff3ba6cf4 (diff)
parent74e339b8f8936bc0d985e053a076d0c9b5e9ea51 (diff)
* New upstream release (http://www.openssh.com/txt/release-6.3).
- sftp(1): add support for resuming partial downloads using the "reget" command and on the sftp commandline or on the "get" commandline using the "-a" (append) option (closes: #158590). - ssh(1): add an "IgnoreUnknown" configuration option to selectively suppress errors arising from unknown configuration directives (closes: #436052). - sftp(1): update progressmeter when data is acknowledged, not when it's sent (partially addresses #708372). - ssh(1): do not fatally exit when attempting to cleanup multiplexing- created channels that are incompletely opened (closes: #651357).
Diffstat (limited to 'debian/patches/consolekit.patch')
-rw-r--r--debian/patches/consolekit.patch41
1 files changed, 20 insertions, 21 deletions
diff --git a/debian/patches/consolekit.patch b/debian/patches/consolekit.patch
index 36b3805b9..fd064a848 100644
--- a/debian/patches/consolekit.patch
+++ b/debian/patches/consolekit.patch
@@ -1,7 +1,7 @@
1Description: Add support for registering ConsoleKit sessions on login 1Description: Add support for registering ConsoleKit sessions on login
2Author: Colin Watson <cjwatson@ubuntu.com> 2Author: Colin Watson <cjwatson@ubuntu.com>
3Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1450 3Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1450
4Last-Updated: 2013-05-13 4Last-Updated: 2013-09-14
5 5
6Index: b/Makefile.in 6Index: b/Makefile.in
7=================================================================== 7===================================================================
@@ -21,7 +21,7 @@ Index: b/configure.ac
21=================================================================== 21===================================================================
22--- a/configure.ac 22--- a/configure.ac
23+++ b/configure.ac 23+++ b/configure.ac
24@@ -3801,6 +3801,30 @@ 24@@ -3841,6 +3841,30 @@
25 AC_SUBST([GSSLIBS]) 25 AC_SUBST([GSSLIBS])
26 AC_SUBST([K5LIBS]) 26 AC_SUBST([K5LIBS])
27 27
@@ -52,7 +52,7 @@ Index: b/configure.ac
52 # Looking for programs, paths and files 52 # Looking for programs, paths and files
53 53
54 PRIVSEP_PATH=/var/empty 54 PRIVSEP_PATH=/var/empty
55@@ -4600,6 +4624,7 @@ 55@@ -4641,6 +4665,7 @@
56 echo " libedit support: $LIBEDIT_MSG" 56 echo " libedit support: $LIBEDIT_MSG"
57 echo " Solaris process contract support: $SPC_MSG" 57 echo " Solaris process contract support: $SPC_MSG"
58 echo " Solaris project support: $SP_MSG" 58 echo " Solaris project support: $SP_MSG"
@@ -64,7 +64,7 @@ Index: b/configure
64=================================================================== 64===================================================================
65--- a/configure 65--- a/configure
66+++ b/configure 66+++ b/configure
67@@ -737,6 +737,7 @@ 67@@ -738,6 +738,7 @@
68 with_sandbox 68 with_sandbox
69 with_selinux 69 with_selinux
70 with_kerberos5 70 with_kerberos5
@@ -72,7 +72,7 @@ Index: b/configure
72 with_privsep_path 72 with_privsep_path
73 with_xauth 73 with_xauth
74 enable_strip 74 enable_strip
75@@ -1427,6 +1428,7 @@ 75@@ -1428,6 +1429,7 @@
76 --with-sandbox=style Specify privilege separation sandbox (no, darwin, rlimit, systrace, seccomp_filter) 76 --with-sandbox=style Specify privilege separation sandbox (no, darwin, rlimit, systrace, seccomp_filter)
77 --with-selinux Enable SELinux support 77 --with-selinux Enable SELinux support
78 --with-kerberos5=PATH Enable Kerberos 5 support 78 --with-kerberos5=PATH Enable Kerberos 5 support
@@ -80,7 +80,7 @@ Index: b/configure
80 --with-privsep-path=xxx Path for privilege separation chroot (default=/var/empty) 80 --with-privsep-path=xxx Path for privilege separation chroot (default=/var/empty)
81 --with-xauth=PATH Specify path to xauth program 81 --with-xauth=PATH Specify path to xauth program
82 --with-maildir=/path/to/mail Specify your system mail directory 82 --with-maildir=/path/to/mail Specify your system mail directory
83@@ -16002,6 +16004,135 @@ 83@@ -16375,6 +16377,135 @@
84 84
85 85
86 86
@@ -216,7 +216,7 @@ Index: b/configure
216 # Looking for programs, paths and files 216 # Looking for programs, paths and files
217 217
218 PRIVSEP_PATH=/var/empty 218 PRIVSEP_PATH=/var/empty
219@@ -18527,6 +18658,7 @@ 219@@ -18902,6 +19033,7 @@
220 echo " libedit support: $LIBEDIT_MSG" 220 echo " libedit support: $LIBEDIT_MSG"
221 echo " Solaris process contract support: $SPC_MSG" 221 echo " Solaris process contract support: $SPC_MSG"
222 echo " Solaris project support: $SP_MSG" 222 echo " Solaris project support: $SP_MSG"
@@ -502,17 +502,17 @@ Index: b/monitor.c
502=================================================================== 502===================================================================
503--- a/monitor.c 503--- a/monitor.c
504+++ b/monitor.c 504+++ b/monitor.c
505@@ -97,6 +97,9 @@ 505@@ -98,6 +98,9 @@
506 #include "ssh2.h"
507 #include "jpake.h" 506 #include "jpake.h"
508 #include "roaming.h" 507 #include "roaming.h"
508 #include "authfd.h"
509+#ifdef USE_CONSOLEKIT 509+#ifdef USE_CONSOLEKIT
510+#include "consolekit.h" 510+#include "consolekit.h"
511+#endif 511+#endif
512 512
513 #ifdef GSSAPI 513 #ifdef GSSAPI
514 static Gssctxt *gsscontext = NULL; 514 static Gssctxt *gsscontext = NULL;
515@@ -192,6 +195,10 @@ 515@@ -193,6 +196,10 @@
516 516
517 static int monitor_read_log(struct monitor *); 517 static int monitor_read_log(struct monitor *);
518 518
@@ -523,7 +523,7 @@ Index: b/monitor.c
523 static Authctxt *authctxt; 523 static Authctxt *authctxt;
524 static BIGNUM *ssh1_challenge = NULL; /* used for ssh1 rsa auth */ 524 static BIGNUM *ssh1_challenge = NULL; /* used for ssh1 rsa auth */
525 525
526@@ -284,6 +291,9 @@ 526@@ -285,6 +292,9 @@
527 {MONITOR_REQ_AUDIT_EVENT, MON_PERMIT, mm_answer_audit_event}, 527 {MONITOR_REQ_AUDIT_EVENT, MON_PERMIT, mm_answer_audit_event},
528 {MONITOR_REQ_AUDIT_COMMAND, MON_PERMIT, mm_answer_audit_command}, 528 {MONITOR_REQ_AUDIT_COMMAND, MON_PERMIT, mm_answer_audit_command},
529 #endif 529 #endif
@@ -533,7 +533,7 @@ Index: b/monitor.c
533 {0, 0, NULL} 533 {0, 0, NULL}
534 }; 534 };
535 535
536@@ -326,6 +336,9 @@ 536@@ -327,6 +337,9 @@
537 {MONITOR_REQ_AUDIT_EVENT, MON_PERMIT, mm_answer_audit_event}, 537 {MONITOR_REQ_AUDIT_EVENT, MON_PERMIT, mm_answer_audit_event},
538 {MONITOR_REQ_AUDIT_COMMAND, MON_PERMIT|MON_ONCE, mm_answer_audit_command}, 538 {MONITOR_REQ_AUDIT_COMMAND, MON_PERMIT|MON_ONCE, mm_answer_audit_command},
539 #endif 539 #endif
@@ -553,7 +553,7 @@ Index: b/monitor.c
553 553
554 for (;;) 554 for (;;)
555 monitor_read(pmonitor, mon_dispatch, NULL); 555 monitor_read(pmonitor, mon_dispatch, NULL);
556@@ -2472,3 +2488,31 @@ 556@@ -2492,3 +2508,30 @@
557 } 557 }
558 558
559 #endif /* JPAKE */ 559 #endif /* JPAKE */
@@ -577,10 +577,9 @@ Index: b/monitor.c
577+ buffer_put_cstring(m, cookie != NULL ? cookie : ""); 577+ buffer_put_cstring(m, cookie != NULL ? cookie : "");
578+ mm_request_send(sock, MONITOR_ANS_CONSOLEKIT_REGISTER, m); 578+ mm_request_send(sock, MONITOR_ANS_CONSOLEKIT_REGISTER, m);
579+ 579+
580+ if (cookie != NULL) 580+ free(cookie);
581+ xfree(cookie); 581+ free(display);
582+ xfree(display); 582+ free(tty);
583+ xfree(tty);
584+ 583+
585+ return (0); 584+ return (0);
586+} 585+}
@@ -602,7 +601,7 @@ Index: b/monitor_wrap.c
602=================================================================== 601===================================================================
603--- a/monitor_wrap.c 602--- a/monitor_wrap.c
604+++ b/monitor_wrap.c 603+++ b/monitor_wrap.c
605@@ -1514,3 +1514,34 @@ 604@@ -1516,3 +1516,34 @@
606 return success; 605 return success;
607 } 606 }
608 #endif /* JPAKE */ 607 #endif /* JPAKE */
@@ -631,7 +630,7 @@ Index: b/monitor_wrap.c
631+ 630+
632+ /* treat empty cookie as missing cookie */ 631+ /* treat empty cookie as missing cookie */
633+ if (strlen(cookie) == 0) { 632+ if (strlen(cookie) == 0) {
634+ xfree(cookie); 633+ free(cookie);
635+ cookie = NULL; 634+ cookie = NULL;
636+ } 635+ }
637+ return (cookie); 636+ return (cookie);
@@ -654,7 +653,7 @@ Index: b/session.c
654=================================================================== 653===================================================================
655--- a/session.c 654--- a/session.c
656+++ b/session.c 655+++ b/session.c
657@@ -91,6 +91,7 @@ 656@@ -92,6 +92,7 @@
658 #include "kex.h" 657 #include "kex.h"
659 #include "monitor_wrap.h" 658 #include "monitor_wrap.h"
660 #include "sftp.h" 659 #include "sftp.h"
@@ -684,7 +683,7 @@ Index: b/session.c
684 #ifdef USE_PAM 683 #ifdef USE_PAM
685 /* 684 /*
686 * Pull in any environment variables that may have 685 * Pull in any environment variables that may have
687@@ -2308,6 +2317,10 @@ 686@@ -2320,6 +2329,10 @@
688 687
689 debug("session_pty_cleanup: session %d release %s", s->self, s->tty); 688 debug("session_pty_cleanup: session %d release %s", s->self, s->tty);
690 689