diff options
author | Colin Watson <cjwatson@debian.org> | 2019-10-09 22:59:48 +0100 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2019-10-09 23:39:39 +0100 |
commit | 767ee84d3465b6d244a9108de5c167a9ab866df9 (patch) | |
tree | 69b14ef6a62d7f133298a21d2ad6046f130b7801 /debian/patches/fix-interop-tests.patch | |
parent | ddeaf9ee7d5c6612b88f1c4a83fc6fbccb93bf60 (diff) | |
parent | efef12825b9582c1710da3b7e50135870963d4f4 (diff) |
New upstream release (8.1p1)
Diffstat (limited to 'debian/patches/fix-interop-tests.patch')
-rw-r--r-- | debian/patches/fix-interop-tests.patch | 71 |
1 files changed, 0 insertions, 71 deletions
diff --git a/debian/patches/fix-interop-tests.patch b/debian/patches/fix-interop-tests.patch deleted file mode 100644 index e00842290..000000000 --- a/debian/patches/fix-interop-tests.patch +++ /dev/null | |||
@@ -1,71 +0,0 @@ | |||
1 | From 42519a0f32765726ccd18a14aa6e877413a69662 Mon Sep 17 00:00:00 2001 | ||
2 | From: Colin Watson <cjwatson@debian.org> | ||
3 | Date: Fri, 14 Jun 2019 11:57:15 +0100 | ||
4 | Subject: Fix interop tests for recent regress changes | ||
5 | |||
6 | A recent regress change (2a9b3a2ce411d16cda9c79ab713c55f65b0ec257 in | ||
7 | portable) broke the PuTTY and Twisted Conch interop tests, because the | ||
8 | key they want to use is now called ssh-rsa rather than rsa. Fix them. | ||
9 | |||
10 | Forwarded: https://bugzilla.mindrot.org/show_bug.cgi?id=3020 | ||
11 | Last-Update: 2019-06-14 | ||
12 | |||
13 | Patch-Name: fix-interop-tests.patch | ||
14 | --- | ||
15 | regress/Makefile | 5 +++-- | ||
16 | regress/conch-ciphers.sh | 2 +- | ||
17 | regress/test-exec.sh | 10 +++++----- | ||
18 | 3 files changed, 9 insertions(+), 8 deletions(-) | ||
19 | |||
20 | diff --git a/regress/Makefile b/regress/Makefile | ||
21 | index 925edf71a..781400fd0 100644 | ||
22 | --- a/regress/Makefile | ||
23 | +++ b/regress/Makefile | ||
24 | @@ -113,8 +113,9 @@ CLEANFILES= *.core actual agent-key.* authorized_keys_${USERNAME} \ | ||
25 | rsa1 rsa1-agent rsa1-agent.pub rsa1.pub rsa_ssh2_cr.prv \ | ||
26 | rsa_ssh2_crnl.prv scp-ssh-wrapper.exe \ | ||
27 | scp-ssh-wrapper.scp setuid-allowed sftp-server.log \ | ||
28 | - sftp-server.sh sftp.log ssh-log-wrapper.sh ssh.log \ | ||
29 | - ssh_config ssh_config.* ssh_proxy ssh_proxy_bak \ | ||
30 | + sftp-server.sh sftp.log ssh-log-wrapper.sh \ | ||
31 | + ssh-rsa_oldfmt \ | ||
32 | + ssh.log ssh_config ssh_config.* ssh_proxy ssh_proxy_bak \ | ||
33 | ssh_proxy_envpass sshd.log sshd_config sshd_config_minimal \ | ||
34 | sshd_config.orig sshd_proxy sshd_proxy.* sshd_proxy_bak \ | ||
35 | sshd_proxy_orig t10.out t10.out.pub t12.out t12.out.pub \ | ||
36 | diff --git a/regress/conch-ciphers.sh b/regress/conch-ciphers.sh | ||
37 | index 199d863a0..51e3b705f 100644 | ||
38 | --- a/regress/conch-ciphers.sh | ||
39 | +++ b/regress/conch-ciphers.sh | ||
40 | @@ -16,7 +16,7 @@ for c in aes256-ctr aes256-cbc aes192-ctr aes192-cbc aes128-ctr aes128-cbc \ | ||
41 | rm -f ${COPY} | ||
42 | # XXX the 2nd "cat" seems to be needed because of buggy FD handling | ||
43 | # in conch | ||
44 | - ${CONCH} --identity $OBJ/rsa --port $PORT --user $USER -e none \ | ||
45 | + ${CONCH} --identity $OBJ/ssh-rsa --port $PORT --user $USER -e none \ | ||
46 | --known-hosts $OBJ/known_hosts --notty --noagent --nox11 -n \ | ||
47 | 127.0.0.1 "cat ${DATA}" 2>/dev/null | cat > ${COPY} | ||
48 | if [ $? -ne 0 ]; then | ||
49 | diff --git a/regress/test-exec.sh b/regress/test-exec.sh | ||
50 | index b8e2009de..efde6a173 100644 | ||
51 | --- a/regress/test-exec.sh | ||
52 | +++ b/regress/test-exec.sh | ||
53 | @@ -527,13 +527,13 @@ if test "$REGRESS_INTEROP_PUTTY" = "yes" ; then | ||
54 | >> $OBJ/authorized_keys_$USER | ||
55 | |||
56 | # Convert rsa2 host key to PuTTY format | ||
57 | - cp $OBJ/rsa $OBJ/rsa_oldfmt | ||
58 | - ${SSHKEYGEN} -p -N '' -m PEM -f $OBJ/rsa_oldfmt >/dev/null | ||
59 | - ${SRC}/ssh2putty.sh 127.0.0.1 $PORT $OBJ/rsa_oldfmt > \ | ||
60 | + cp $OBJ/ssh-rsa $OBJ/ssh-rsa_oldfmt | ||
61 | + ${SSHKEYGEN} -p -N '' -m PEM -f $OBJ/ssh-rsa_oldfmt >/dev/null | ||
62 | + ${SRC}/ssh2putty.sh 127.0.0.1 $PORT $OBJ/ssh-rsa_oldfmt > \ | ||
63 | ${OBJ}/.putty/sshhostkeys | ||
64 | - ${SRC}/ssh2putty.sh 127.0.0.1 22 $OBJ/rsa_oldfmt >> \ | ||
65 | + ${SRC}/ssh2putty.sh 127.0.0.1 22 $OBJ/ssh-rsa_oldfmt >> \ | ||
66 | ${OBJ}/.putty/sshhostkeys | ||
67 | - rm -f $OBJ/rsa_oldfmt | ||
68 | + rm -f $OBJ/ssh-rsa_oldfmt | ||
69 | |||
70 | # Setup proxied session | ||
71 | mkdir -p ${OBJ}/.putty/sessions | ||