diff options
author | Colin Watson <cjwatson@debian.org> | 2003-09-01 18:21:02 +0000 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2003-09-01 18:21:02 +0000 |
commit | 0bb3622af79c6402a15e88ce1290cbc776392403 (patch) | |
tree | 0b4cf129e0c2f9654e9de22977cbe276bf03e406 /debian/rules | |
parent | 2b89c091812295ccae1542bdf2c58b7128975192 (diff) |
Debian release 3.5p1-3.
Diffstat (limited to 'debian/rules')
-rwxr-xr-x | debian/rules | 16 |
1 files changed, 6 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules index fb60b2270..42ecea8ef 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -21,7 +21,7 @@ build-stamp: | |||
21 | fi | 21 | fi |
22 | ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-ipv4-default \ | 22 | ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-ipv4-default \ |
23 | --with-privsep-path=/var/run/sshd --without-rand-helper | 23 | --with-privsep-path=/var/run/sshd --without-rand-helper |
24 | $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-O2 -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \ | 24 | $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-O2 -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \ |
25 | SSH_KEYSIGN='/usr/lib/ssh-keysign' | 25 | SSH_KEYSIGN='/usr/lib/ssh-keysign' |
26 | $(MAKE) -C contrib gnome-ssh-askpass1 CC='gcc -O2' | 26 | $(MAKE) -C contrib gnome-ssh-askpass1 CC='gcc -O2' |
27 | 27 | ||
@@ -45,25 +45,25 @@ install: build | |||
45 | dh_installdirs | 45 | dh_installdirs |
46 | 46 | ||
47 | # Add here commands to install the package into debian/tmp. | 47 | # Add here commands to install the package into debian/tmp. |
48 | $(MAKE) DESTDIR=`pwd`/debian/tmp install | 48 | $(MAKE) DESTDIR=`pwd`/debian/tmp install-nokeys |
49 | 49 | ||
50 | rm -f debian/tmp/etc/ssh/ssh_host_*key* | ||
51 | rm -f debian/tmp/etc/ssh/sshd_config | 50 | rm -f debian/tmp/etc/ssh/sshd_config |
52 | #Temporary hack: remove /usr/share/Ssh.bin, since we have no smartcard support anyway. | 51 | #Temporary hack: remove /usr/share/Ssh.bin, since we have no smartcard support anyway. |
53 | rm -f debian/tmp/usr/share/Ssh.bin | 52 | rm -f debian/tmp/usr/share/Ssh.bin |
54 | 53 | ||
55 | install -m 755 contrib/ssh-copy-id debian/tmp/usr/bin/ssh-copy-id | 54 | install -m 755 contrib/ssh-copy-id debian/tmp/usr/bin/ssh-copy-id |
56 | install -m 644 -c contrib/ssh-copy-id.1 debian/tmp/usr/share/man/man1/ssh-copy-id.1 | 55 | install -m 644 -c contrib/ssh-copy-id.1 debian/tmp/usr/share/man/man1/ssh-copy-id.1 |
57 | install -m 644 debian/gnome-ssh-askpass.1 debian/tmp/usr/share/man/man1/gnome-ssh-askpass.1 | ||
58 | 56 | ||
59 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass1 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass | 57 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass1 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass |
58 | install -m 644 debian/gnome-ssh-askpass.1 debian/ssh-askpass-gnome/usr/share/man/man1/gnome-ssh-askpass.1 | ||
59 | |||
60 | install -m 755 debian/ssh-argv0 debian/tmp/usr/bin/ssh-argv0 | ||
61 | install -m 644 debian/ssh-argv0.1 debian/tmp/usr/share/man/man1/ssh-argv0.1 | ||
60 | 62 | ||
61 | install -o root -g root debian/init debian/tmp/etc/init.d/ssh | 63 | install -o root -g root debian/init debian/tmp/etc/init.d/ssh |
62 | 64 | ||
63 | install -o root -g root -m 755 -d debian/tmp/var/run/sshd | 65 | install -o root -g root -m 755 -d debian/tmp/var/run/sshd |
64 | 66 | ||
65 | dh_movefiles | ||
66 | |||
67 | # Build architecture-independent files here. | 67 | # Build architecture-independent files here. |
68 | binary-indep: build install | 68 | binary-indep: build install |
69 | # nothing to do | 69 | # nothing to do |
@@ -75,16 +75,12 @@ binary-arch: build install | |||
75 | dh_installdebconf | 75 | dh_installdebconf |
76 | dh_installdocs OVERVIEW README | 76 | dh_installdocs OVERVIEW README |
77 | cat debian/copyright.head LICENCE > debian/tmp/usr/share/doc/ssh/copyright | 77 | cat debian/copyright.head LICENCE > debian/tmp/usr/share/doc/ssh/copyright |
78 | dh_installexamples | ||
79 | dh_installmenu | ||
80 | nroff RFC.nroff > debian/tmp/usr/share/doc/ssh/RFC | 78 | nroff RFC.nroff > debian/tmp/usr/share/doc/ssh/RFC |
81 | gzip -9 debian/tmp/usr/share/doc/ssh/RFC | 79 | gzip -9 debian/tmp/usr/share/doc/ssh/RFC |
82 | rm -rf debian/tmp/usr/share/doc/ssh/RFC.nroff.gz | 80 | rm -rf debian/tmp/usr/share/doc/ssh/RFC.nroff.gz |
83 | dh_installpam | 81 | dh_installpam |
84 | dh_installcron | ||
85 | dh_installchangelogs ChangeLog | 82 | dh_installchangelogs ChangeLog |
86 | dh_strip | 83 | dh_strip |
87 | dh_link | ||
88 | dh_compress | 84 | dh_compress |
89 | dh_fixperms | 85 | dh_fixperms |
90 | dh_installdeb | 86 | dh_installdeb |