diff options
author | Colin Watson <cjwatson@debian.org> | 2004-05-11 21:29:18 +0000 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2004-05-11 21:29:18 +0000 |
commit | 32d3d1f6b8d1a02b3182c3ccfedf1d54433b1e30 (patch) | |
tree | 3a791a5e3dba8e764fef5e1d9e75cfbd70e223e5 /debian/rules | |
parent | 2d12cf754ee3eee72b2066d441f0adcf695cec72 (diff) |
Work around lack of res_query weak alias in libresolv on amd64 (see
#242462, awaiting real fix upstream).
Diffstat (limited to 'debian/rules')
-rwxr-xr-x | debian/rules | 10 |
1 files changed, 8 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules index 54c6c1482..e65f47d1e 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -43,6 +43,12 @@ PAMSUBST := yes | |||
43 | PAMDEP := libpam-runtime | 43 | PAMDEP := libpam-runtime |
44 | endif | 44 | endif |
45 | 45 | ||
46 | # Temporary linkage hack for amd64 due to lack of res_query weak alias, see | ||
47 | # #242462. Real fix sent upstream. | ||
48 | ifeq ($(DEB_HOST_ARCH),amd64) | ||
49 | FORCE_LIBS = LIBS=-lresolv | ||
50 | endif | ||
51 | |||
46 | # Change the version string to include the Debian version | 52 | # Change the version string to include the Debian version |
47 | SSH_VERSION := $(shell sed -e '/define/!d; s/.*\"\(.*\)\".*/\1/; q' <version.h) Debian $(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p') | 53 | SSH_VERSION := $(shell sed -e '/define/!d; s/.*\"\(.*\)\".*/\1/; q' <version.h) Debian $(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p') |
48 | 54 | ||
@@ -52,7 +58,7 @@ build-deb: build-deb-stamp | |||
52 | build-deb-stamp: | 58 | build-deb-stamp: |
53 | dh_testdir | 59 | dh_testdir |
54 | mkdir -p build-deb | 60 | mkdir -p build-deb |
55 | cd build-deb && ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper | 61 | cd build-deb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper |
56 | # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). | 62 | # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). |
57 | perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h | 63 | perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h |
58 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' | 64 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' |
@@ -69,7 +75,7 @@ build-udeb: build-udeb-stamp | |||
69 | build-udeb-stamp: | 75 | build-udeb-stamp: |
70 | dh_testdir | 76 | dh_testdir |
71 | mkdir -p build-udeb | 77 | mkdir -p build-udeb |
72 | cd build-udeb && ../configure --prefix=/usr --sysconfdir=/etc/ssh --without-xauth --with-default-path=/usr/local/bin:/bin:/usr/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper | 78 | cd build-udeb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --without-xauth --with-default-path=/usr/local/bin:/bin:/usr/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper |
73 | $(MAKE) -C build-udeb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-Os -g -Wall -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' ssh sshd | 79 | $(MAKE) -C build-udeb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-Os -g -Wall -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' ssh sshd |
74 | touch build-udeb-stamp | 80 | touch build-udeb-stamp |
75 | 81 | ||