diff options
author | Colin Watson <cjwatson@debian.org> | 2007-06-12 19:38:29 +0000 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2007-06-12 19:38:29 +0000 |
commit | 378742206f9e50ecec3f5871b1ce9658a5e8c889 (patch) | |
tree | d73bf23494c1f770123cb32cfb72bba90b1ec30d /debian/rules | |
parent | 1ed76434cb6beaaec975279e1d202bb111400e28 (diff) |
* If building on Ubuntu, add /sbin, /usr/sbin, and /usr/local/sbin to the
default path.
Diffstat (limited to 'debian/rules')
-rwxr-xr-x | debian/rules | 10 |
1 files changed, 9 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules index 76dc5d83c..6e335cf6e 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -62,13 +62,21 @@ endif | |||
62 | # Change the version string to include the Debian version | 62 | # Change the version string to include the Debian version |
63 | SSH_EXTRAVERSION := Debian-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//') | 63 | SSH_EXTRAVERSION := Debian-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//') |
64 | 64 | ||
65 | DISTRIBUTOR := $(shell lsb_release -is || echo Debian) | ||
66 | ifeq ($(DISTRIBUTOR),Ubuntu) | ||
67 | DEFAULT_PATH := /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games | ||
68 | else | ||
69 | DEFAULT_PATH := /usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games | ||
70 | endif | ||
71 | SUPERUSER_PATH := /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11 | ||
72 | |||
65 | build: build-deb build-udeb | 73 | build: build-deb build-udeb |
66 | 74 | ||
67 | build-deb: build-deb-stamp | 75 | build-deb: build-deb-stamp |
68 | build-deb-stamp: | 76 | build-deb-stamp: |
69 | dh_testdir | 77 | dh_testdir |
70 | mkdir -p build-deb | 78 | mkdir -p build-deb |
71 | cd build-deb && $(FORCE_LIBS) LDFLAGS='$(PIE_LDFLAGS)' ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games --with-superuser-path=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11 --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper --with-libedit --with-kerberos5=/usr --with-ssl-engine $(SELINUX) | 79 | cd build-deb && $(FORCE_LIBS) LDFLAGS='$(PIE_LDFLAGS)' ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=$(DEFAULT_PATH) --with-superuser-path=$(SUPERUSER_PATH) --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper --with-libedit --with-kerberos5=/usr --with-ssl-engine $(SELINUX) |
72 | 80 | ||
73 | ifeq ($(DEB_HOST_ARCH_OS),linux) | 81 | ifeq ($(DEB_HOST_ARCH_OS),linux) |
74 | # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). | 82 | # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). |