summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2006-12-23 18:35:21 +0000
committerColin Watson <cjwatson@debian.org>2006-12-23 18:35:21 +0000
commitae04de0cb0a8b65548e009b4c3a03ba7f882e95a (patch)
tree002b0415576f0581ef3f866261951ddb9fe2eb8b /debian/rules
parent309e8aeed9f3d4b7b5e9ad7089889533023b6e73 (diff)
* It turns out that the people who told me that removing a conffile in the
preinst was sufficient to have dpkg replace it without prompting when moving a conffile between packages were very much mistaken. As far as I can tell, the only way to do this reliably is to write out the desired new text of the conffile in the preinst. This is gross, and requires shipping the text of all conffiles in the preinst too, but there's nothing for it. Fortunately this nonsense is only required for smooth upgrades from sarge.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 4d9269666..fdef12dcf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -195,6 +195,10 @@ binary-openssh-client: build install
195 dh_installdeb 195 dh_installdeb
196 test ! -e debian/ssh/etc/ssh/ssh_prng_cmds \ 196 test ! -e debian/ssh/etc/ssh/ssh_prng_cmds \
197 || echo "/etc/ssh/ssh_prng_cmds" >> debian/openssh-client/DEBIAN/conffiles 197 || echo "/etc/ssh/ssh_prng_cmds" >> debian/openssh-client/DEBIAN/conffiles
198 perl -i debian/substitute-conffile.pl \
199 ETC_SSH_MODULI debian/openssh-client/etc/ssh/moduli \
200 ETC_SSH_SSH_CONFIG debian/openssh-client/etc/ssh/ssh_config \
201 debian/openssh-client/DEBIAN/preinst
198 dh_shlibdeps 202 dh_shlibdeps
199 dh_gencontrol -- -V'debconf-depends=debconf (>= $(MINDEBCONFVER)) | debconf-2.0' 203 dh_gencontrol -- -V'debconf-depends=debconf (>= $(MINDEBCONFVER)) | debconf-2.0'
200 dh_md5sums 204 dh_md5sums
@@ -229,6 +233,11 @@ endif
229 dh_compress 233 dh_compress
230 dh_fixperms 234 dh_fixperms
231 dh_installdeb 235 dh_installdeb
236 perl -i debian/substitute-conffile.pl \
237 ETC_DEFAULT_SSH debian/openssh-server/etc/default/ssh \
238 ETC_INIT_D_SSH debian/openssh-server/etc/init.d/ssh \
239 ETC_PAM_D_SSH debian/openssh-server/etc/pam.d/ssh \
240 debian/openssh-server/DEBIAN/preinst
232 dh_shlibdeps 241 dh_shlibdeps
233 dh_gencontrol -- -V'debconf-depends=debconf (>= $(MINDEBCONFVER)) | debconf-2.0' \ 242 dh_gencontrol -- -V'debconf-depends=debconf (>= $(MINDEBCONFVER)) | debconf-2.0' \
234 -V'pam-depends=$(PAMDEP)' 243 -V'pam-depends=$(PAMDEP)'