diff options
author | Colin Watson <cjwatson@debian.org> | 2005-06-01 17:06:42 +0000 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2005-06-01 17:06:42 +0000 |
commit | 34090e04a26eaf4c043c2b6bffaa1cb2e0eac1ff (patch) | |
tree | 009503d673073eeb2d214c1f79f300c7c1109bbd /debian/rules | |
parent | 9bc71eba65432b1dc61f8be4d6dbb1d1a89eebc2 (diff) |
Fix DEB_HOST_ARCH_OS/DEB_HOST_GNU_SYSTEM compatibility handling.
Diffstat (limited to 'debian/rules')
-rwxr-xr-x | debian/rules | 16 |
1 files changed, 12 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules index 0398cbaa7..ce831e55d 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -17,7 +17,15 @@ endif | |||
17 | 17 | ||
18 | VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2 | sed 's/.*://') | 18 | VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2 | sed 's/.*://') |
19 | DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH) | 19 | DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH) |
20 | DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null || dpkg-architecture -qDEB_HOST_GNU_SYSTEM) | 20 | DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null) |
21 | |||
22 | # Take account of old dpkg-architecture output. | ||
23 | ifeq ($(DEB_HOST_ARCH_OS),) | ||
24 | DEB_HOST_ARCH_OS := $(subst -gnu,,$(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)) | ||
25 | ifeq ($(DEB_HOST_ARCH_OS),gnu) | ||
26 | DEB_HOST_ARCH_OS := hurd | ||
27 | endif | ||
28 | endif | ||
21 | 29 | ||
22 | CLIENT_UDEB := openssh-client-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb | 30 | CLIENT_UDEB := openssh-client-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb |
23 | SERVER_UDEB := openssh-server-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb | 31 | SERVER_UDEB := openssh-server-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb |
@@ -45,7 +53,7 @@ PAMDEP := libpam-runtime | |||
45 | endif | 53 | endif |
46 | 54 | ||
47 | # The Hurd needs libcrypt for res_query et al. | 55 | # The Hurd needs libcrypt for res_query et al. |
48 | ifeq ($(DEB_HOST_ARCH_OS),gnu) | 56 | ifeq ($(DEB_HOST_ARCH_OS),hurd) |
49 | FORCE_LIBS := LIBS=-lcrypt | 57 | FORCE_LIBS := LIBS=-lcrypt |
50 | endif | 58 | endif |
51 | 59 | ||
@@ -134,7 +142,7 @@ install: build | |||
134 | install -m 644 -c contrib/ssh-copy-id.1 debian/openssh-client/usr/share/man/man1/ssh-copy-id.1 | 142 | install -m 644 -c contrib/ssh-copy-id.1 debian/openssh-client/usr/share/man/man1/ssh-copy-id.1 |
135 | install -m 644 debian/moduli.5 debian/openssh-client/usr/share/man/man5/moduli.5 | 143 | install -m 644 debian/moduli.5 debian/openssh-client/usr/share/man/man5/moduli.5 |
136 | 144 | ||
137 | ifneq ($(DEB_HOST_ARCH_OS),gnu) | 145 | ifneq ($(DEB_HOST_ARCH_OS),hurd) |
138 | if [ -f contrib/gnome-ssh-askpass2 ]; then \ | 146 | if [ -f contrib/gnome-ssh-askpass2 ]; then \ |
139 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/openssh/gnome-ssh-askpass; \ | 147 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/openssh/gnome-ssh-askpass; \ |
140 | elif [ -f contrib/gnome-ssh-askpass1 ]; then \ | 148 | elif [ -f contrib/gnome-ssh-askpass1 ]; then \ |
@@ -161,7 +169,7 @@ binary-indep: binary-ssh | |||
161 | 169 | ||
162 | # Build architecture-dependent files here. | 170 | # Build architecture-dependent files here. |
163 | binary-arch: binary-openssh-client binary-openssh-server | 171 | binary-arch: binary-openssh-client binary-openssh-server |
164 | ifneq ($(DEB_HOST_ARCH_OS),gnu) | 172 | ifneq ($(DEB_HOST_ARCH_OS),hurd) |
165 | binary-arch: binary-ssh-askpass-gnome | 173 | binary-arch: binary-ssh-askpass-gnome |
166 | endif | 174 | endif |
167 | binary-arch: binary-openssh-client-udeb binary-openssh-server-udeb | 175 | binary-arch: binary-openssh-client-udeb binary-openssh-server-udeb |