summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2013-07-02 22:54:42 +0100
committerColin Watson <cjwatson@debian.org>2013-07-02 22:54:42 +0100
commit0edc274d28d59b8202a574761288e3a25dda91f7 (patch)
treea8b465f17d86efeb87d09c81ae8d5fb68fd3742c /debian/rules
parent56ccfc0acea3aa1301821bc822ab2b3913b6e971 (diff)
Update config.guess and config.sub automatically at build time.
dh_autoreconf does not take care of that by default because openssh does not use automake.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index cb7932e3b..d53bafa4c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -116,6 +116,13 @@ confflags_udeb += --with-ldflags='-Wl,--as-needed'
116%: 116%:
117 dh $@ --with=autoreconf 117 dh $@ --with=autoreconf
118 118
119autoreconf:
120 autoreconf -f -i
121 cp -f /usr/share/misc/config.guess /usr/share/misc/config.sub ./
122
123override_dh_autoreconf:
124 dh_autoreconf debian/rules -- autoreconf
125
119override_dh_auto_configure: 126override_dh_auto_configure:
120 dh_auto_configure -Bbuild-deb -- $(confflags) 127 dh_auto_configure -Bbuild-deb -- $(confflags)
121 dh_auto_configure -Bbuild-udeb -- $(confflags_udeb) 128 dh_auto_configure -Bbuild-udeb -- $(confflags_udeb)