summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2007-11-17 20:00:10 +0000
committerColin Watson <cjwatson@debian.org>2007-11-17 20:00:10 +0000
commit2a87bee9f8e6bf325cd6525e6ac5cca58ac39586 (patch)
tree6973ebb7878a5875b5dfe36e7b614b30e76148ed /debian/rules
parenta660ece98c5a924a6dc29379419fdcb113451319 (diff)
* Use autotools-dev's recommended configure --build and --host options.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 11 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 13363341e..14c10e7d1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,15 @@ else
12OPTFLAGS := -O0 12OPTFLAGS := -O0
13endif 13endif
14 14
15DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
17
18ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
19 confflags += --build=$(DEB_HOST_GNU_TYPE)
20else
21 confflags += --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
22endif
23
15DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null) 24DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null)
16DEB_HOST_ARCH_CPU := $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU 2>/dev/null) 25DEB_HOST_ARCH_CPU := $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU 2>/dev/null)
17 26
@@ -87,7 +96,7 @@ build-deb: build-deb-stamp
87build-deb-stamp: 96build-deb-stamp:
88 dh_testdir 97 dh_testdir
89 mkdir -p build-deb 98 mkdir -p build-deb
90 cd build-deb && $(FORCE_LIBS) LDFLAGS='$(PIE_LDFLAGS)' ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=$(DEFAULT_PATH) --with-superuser-path=$(SUPERUSER_PATH) --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper --with-libedit --with-kerberos5=/usr --with-ssl-engine $(SELINUX) 99 cd build-deb && $(FORCE_LIBS) LDFLAGS='$(PIE_LDFLAGS)' ../configure $(confflags) --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=$(DEFAULT_PATH) --with-superuser-path=$(SUPERUSER_PATH) --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper --with-libedit --with-kerberos5=/usr --with-ssl-engine $(SELINUX)
91 100
92ifeq ($(DEB_HOST_ARCH_OS),linux) 101ifeq ($(DEB_HOST_ARCH_OS),linux)
93 # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). 102 # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999).
@@ -110,7 +119,7 @@ build-udeb: build-udeb-stamp
110build-udeb-stamp: 119build-udeb-stamp:
111 dh_testdir 120 dh_testdir
112 mkdir -p build-udeb 121 mkdir -p build-udeb
113 cd build-udeb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --without-xauth --with-default-path=/usr/local/bin:/usr/bin:/bin --with-superuser-path=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper 122 cd build-udeb && $(FORCE_LIBS) ../configure $(confflags) --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib/openssh --without-xauth --with-default-path=/usr/local/bin:/usr/bin:/bin --with-superuser-path=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper
114 # Debian's /var/log/btmp has inappropriate permissions. 123 # Debian's /var/log/btmp has inappropriate permissions.
115 perl -pi -e 's,.*#define USE_BTMP .*,/* #undef USE_BTMP */,' build-udeb/config.h 124 perl -pi -e 's,.*#define USE_BTMP .*,/* #undef USE_BTMP */,' build-udeb/config.h
116 # Avoid libnsl linkage. Ugh. 125 # Avoid libnsl linkage. Ugh.