diff options
author | Colin Watson <cjwatson@debian.org> | 2003-09-01 19:03:02 +0000 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2003-09-01 19:03:02 +0000 |
commit | 4a4400f027c87b8b8182ecad3e821c0a0db49df0 (patch) | |
tree | b2ea7235c6f34ddb60f5f7001f23dfcfe1766fa3 /debian/rules | |
parent | 1501d1e253613aba573e163869a2f704abd73a44 (diff) | |
parent | 854156dd39acbde9b4a47ec0fc54a042ea7358e0 (diff) |
Debian release 3.6.1p2-1.
Diffstat (limited to 'debian/rules')
-rwxr-xr-x | debian/rules | 12 |
1 files changed, 9 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules index dcf406f24..d3dcf8df9 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -9,6 +9,12 @@ export DH_COMPAT=1 | |||
9 | # This has to be exported to make some magic below work. | 9 | # This has to be exported to make some magic below work. |
10 | export DH_OPTIONS | 10 | export DH_OPTIONS |
11 | 11 | ||
12 | ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) | ||
13 | OPTFLAGS := -O2 | ||
14 | else | ||
15 | OPTFLAGS := -O0 | ||
16 | endif | ||
17 | |||
12 | #PKG_VER = $(shell perl -e 'print <> =~ /\((.*)\)/' debian/changelog) | 18 | #PKG_VER = $(shell perl -e 'print <> =~ /\((.*)\)/' debian/changelog) |
13 | 19 | ||
14 | build: build-stamp | 20 | build: build-stamp |
@@ -21,13 +27,13 @@ build-stamp: | |||
21 | fi | 27 | fi |
22 | ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 \ | 28 | ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 \ |
23 | --with-privsep-path=/var/run/sshd --without-rand-helper | 29 | --with-privsep-path=/var/run/sshd --without-rand-helper |
24 | $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-O2 -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \ | 30 | $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \ |
25 | SSH_KEYSIGN='/usr/lib/ssh-keysign' | 31 | SSH_KEYSIGN='/usr/lib/ssh-keysign' |
26 | # Support building on Debian 3.0 (with GNOME 1.4) and later. | 32 | # Support building on Debian 3.0 (with GNOME 1.4) and later. |
27 | if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ | 33 | if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ |
28 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc -O2'; \ | 34 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ |
29 | elif [ -f /usr/include/gnome-1.0/gnome.h ]; then \ | 35 | elif [ -f /usr/include/gnome-1.0/gnome.h ]; then \ |
30 | $(MAKE) -C contrib gnome-ssh-askpass1 CC='gcc -O2'; \ | 36 | $(MAKE) -C contrib gnome-ssh-askpass1 CC='gcc $(OPTFLAGS) -g -Wall'; \ |
31 | fi | 37 | fi |
32 | 38 | ||
33 | touch build-stamp | 39 | touch build-stamp |