diff options
author | Colin Watson <cjwatson@debian.org> | 2004-11-01 18:47:20 +0000 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2004-11-01 18:47:20 +0000 |
commit | 1f285e89f8f745d0d474a0582ff2844ef32ec9c7 (patch) | |
tree | 9921e814179caf25244a1f2fa65dd3d5723c1e91 /debian | |
parent | fa2383c5054eda0e38afc90c4bb4f6b0ea34d4d7 (diff) |
Enable threading for PAM, on Sam Hartman's advice (closes: #278394).
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 1 | ||||
-rwxr-xr-x | debian/rules | 6 |
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog index d82cced42..2d6459e53 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -1,5 +1,6 @@ | |||
1 | openssh (1:3.8.1p1-8.sarge.3) UNRELEASED; urgency=low | 1 | openssh (1:3.8.1p1-8.sarge.3) UNRELEASED; urgency=low |
2 | 2 | ||
3 | * Enable threading for PAM, on Sam Hartman's advice (closes: #278394). | ||
3 | * debconf template translations: | 4 | * debconf template translations: |
4 | - Update Dutch (thanks, cobaco; closes: #278715). | 5 | - Update Dutch (thanks, cobaco; closes: #278715). |
5 | 6 | ||
diff --git a/debian/rules b/debian/rules index 06a661239..d088d2701 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -59,9 +59,13 @@ build-deb-stamp: | |||
59 | dh_testdir | 59 | dh_testdir |
60 | mkdir -p build-deb | 60 | mkdir -p build-deb |
61 | cd build-deb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper | 61 | cd build-deb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper |
62 | |||
62 | # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). | 63 | # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). |
63 | perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h | 64 | perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h |
64 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' | 65 | # Supply pthread linkage for just those binaries linked to PAM. |
66 | perl -pi -e 's/^(LIBPAM=.*)/$$1 -pthread/' build-deb/Makefile | ||
67 | |||
68 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DUSE_POSIX_THREADS -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' | ||
65 | # Support building on Debian 3.0 (with GNOME 1.4) and later. | 69 | # Support building on Debian 3.0 (with GNOME 1.4) and later. |
66 | if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ | 70 | if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ |
67 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ | 71 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ |